XP SP3 not allowing any control over the pc

  theDarkness 14:02 05 Jan 2011

One annoying problem - I tried to install old XP software the other day as a test (early 2000s). It proved to be incompatible with SP3, which was what the system had installed. So I tried to uninstall this software, and windows is now telling me I do not have any permission to do so. It is the only account, and it is an admin account.

Aside from no longer having admin control, I have also noticed I do not have permission any longer to restart or shutdown the pc, and I cannot run any programs at all, or use anything within the control panel, so that includes system restore. The main cause could be that "XP cannot access system32/rundll32.exe", possibly due to "not having the appropriate permissions". This message pops up alot, along with "Windows cannot access the specified device" for everything I try and access on the pc, except for images/wallpaper, which is the only file type thats accessible, if only via the standard XP preview.

I have found a way around restarting the pc (switching user without logging off, then restarting) but it does not make any difference at all to the above issue. Does anyone have any ideas on how to solve this one? Thanks :)

  961 14:31 05 Jan 2011

This is one of the enduring problems of Windows XP.

I've found on numerous occasions that trying to install from an original XP disk fails because XP2 and XP3 software is, basically, incompatible

Savvy folks will keep an up to date copy of XP on disk with all the add ons so that they can reinstall

Some others will wipe the drive and start again with, perhaps, 24 hrs of installing updates to get them to where XP is now

No chance of trying System Restore I suppose?

  theDarkness 14:45 05 Jan 2011

I get "Windows cannot access the specified device, path, or file. You may not have the appropriate permission to access the item" on just about all options within the control panel, so there is no access to system restore at all. I cant right click on 'my computer' and select 'properties' either, for admin options, and I thought I could get to system restore via start>run>msconfig, but I get the same message yet again.

Im sure Ive had a similar problem to this before, but Ive no idea how (if) I fixed it, to reset these environment variables (I think thats the terms used) in order for my admin account to have full control in xp once more. I never had the issue in sp3 before though, only sp2.

  961 15:22 05 Jan 2011

I think you need to use safe mode (F8?) and go through the repair options

  theDarkness 16:04 05 Jan 2011

system restore and the main control panel is now accessible in safe mode, although unfortunately no restore dates are available. I was thinking of using safe mode to be able to simply create a new admin account and delete the old one, or (if that doesnt work) try a last resort install-over-the-top for xp (not sure if that last one would help).

I have noticed (after creating a password for my problematic admin account, using safe mode), that there IS a solution to be able to get programs running in normal mode-and thats to right click on any program or shortcut, choose "run as", select the current in use admin user account and type the password. That seems to get me around the issue of nothing being able to work, but I dont fancy having to do that all the time, lol, deleting the old account and creating a new account instead may well be the easiest solution, as I cannot work out how to keep the old account and fix the access problem. thanks

  theDarkness 18:50 05 Jan 2011

update:- both trying a repair by reinstalling xp sp2 over the troublesome sp3, or creating a new admin account and deleting the old, do not work! The system still tells me when booting up yet again that I do not have the correct permissions :( I dont want to have to reinstall xp completely as I dont have extra space on any other hd to save files and folders from this current installation. Im not sure what else I can try.

  Fruit Bat /\0/\ 19:21 05 Jan 2011

Access Files
If you get Access Denied in WinXP Pro. Try “taking ownership” of the file/folder before it can be accessed. First of all go to Folder Options, View Tab and in the Advanced Settings at the end, untick “Use simple file sharing”, which will allow the Security Tab to be shown in the file’s properties. Also, in Folder options, make sure hidden and system files can be viewed.
To take ownership of the file (it’s best done at the folder level), right-click it, Properties, Security Tab, add your user name, fill in all the permissions and Apply. You can now access it.
click here

Access Files XP Home
Simple file sharing is enabled by default in XP Home
Note You must be logged on to the computer with an account that has administrative credentials. If you are running Microsoft Windows XP Home Edition, you must start the computer in safe mode, and then log on with an account that has Administrative rights to have access to the Security tab.
click here
click here and click on the link at part one and download the required program.
Follow the instructions and the security tab will be enabled. PLEASE READ CAREFULLY OR YOU COULD DENY ACCESS TO ALL YOUR FILES.

  theDarkness 21:03 05 Jan 2011

Interestingly, after installing XP SP2 over the top of XP Home (updated to SP3) I can now ONLY see the original problematic user account when I am not in safe mode. This account (and all others I create) are always an admin account, but none let me view or run any files of any type. I cannot run any programs, and I cannot access any control panel options, again, unless im in safe mode. If I restart my system and choose normal mode, the original user account reappears. In safe mode (via another admin account) I can tranfer all of my original user accounts documents to a new account, but all new accounts will act the same in normal mode and not let me run or access anything. I cannot delete the original account in safe mode even after moving all of its files.

Thanks for the security tab option, but that was already visible in safe mode. In normal mode, I cant even right click on any file or folder to even see if a security option is available. In safe mode, I can however see that all my files are actually set to "allow", so the solution must be related to something else?

  woodchip 21:11 05 Jan 2011

Why not just go to Control Panel Create a new Admin User give it a Password, then delete the old admin user

  woodchip 21:12 05 Jan 2011

Remove all other Admins

  theDarkness 21:16 05 Jan 2011

I tried that. I cant use the control panel to create a new admin account unless in safe mode, but it did at least work in safe mode. The problem is that every user account, admin or not, is behaving like the original.

With any new admin account, I simply "dont have the permissions" or "windows cannot access xxx". I cannot delete the original account as it does not show up in safe mode when viewing accounts in the control panel. aargh! lol

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Huawei MateBook X Pro review: Hands-on

The art of 'British' pulp fiction

Best password managers for Mac

TV & streaming : comment regarder le Tournoi des Six Nations 2018 ?