XP slows to a crawl: file gsb32.exe to blame

  SonicBlue 15:43 27 Sep 2003

My son's computer with WinXP has recently slowed to a crawl. Using Ctrl+Alt+Del shows 100% cpu usage by a file called gsb32.exe. Ending the process cures the problem. This file was only recently 'downloaded' from the Internet, though not knowingly, together with a file called QTFont.fo. I have tried moving these files to a temporary directory, but they are immediately recreated back in the Windows System directory, and I get the 'Access denied' message when I try to delete them.
What is gsb32.exe, do I need it, how do I delete it, and where is it likely to have come from?

  powerless 15:45 27 Sep 2003

Sure its not, gdi32.exe?

click here

  bremner 15:48 27 Sep 2003

QTfont sounds like a QuickTime file as for GSB32.exe can't find any reference on Google.

Type msconfig into the Run caommand and under start up see if there is a line relating to this. If there is take the tick out and reboot the machine.

  SonicBlue 16:57 27 Sep 2003

To Powerless:

I've had a look, but it's definately gsb32.exe
BTW, the other file that was downloaded with it is QTfont.for, not QTfont.fo

Mind you, gsb32.exe could be a variant of gdi32

  roy 23:41 27 Sep 2003


Your shortcut etc re GDI32.exe worries me a bit.

In my System32 folder I have a gdi (not gdi32)which I think is an .exe and a gdi32.dll. The help bubble says that they refer to Ms Graphics Device Interface. I have looked at the description etc on Symantec and checked my registry and I do not have the entry to which they refer.
I need to know if the files I have are part of Win XP Home or not. Can you help advise.

SonicBlue sorry to highjack your thread.

  MAJ 23:52 27 Sep 2003

They are part of XP Pro (my OS) so I assume they are also part of XP Home.

  roy 23:59 27 Sep 2003


Thanks for that.

  base64uk 16:50 02 Oct 2003

A friend of mine has also found this process running on her pc, it uses 100% cpu time, and causes the system to shut down (spontaneous reset) here's the file details:
gsb32 / size : 24.5 KB (25,088 bytes) / size on disk : 28.0 KB (28,672 bytes)

I've done multiple searches for this and the only mention I can find is this forum - any further ideas anybody?

  base64uk 20:30 02 Oct 2003

we killed the process in task manager, then using regedit, we found and deleted the entry "GsBVDX" from
we then deleted the GSB32.EXE from windows (and the copy that had been made in prefetch)

Rebooting after those three steps leaves no trace of the pest in task manager, but presumably it resides in an installer somewhere since merely killing the process and deleting the .exe followed by a reboot was not successful

  Twigman 21:53 08 Oct 2003

I have this problem on windows 98SE...file opens, tries to access the internet (well my firewall seems to think so, so I blocked it), at which point it starts to not respond, and stays there until i end task it or shut down. Although I can use my computer in the mean time.
It also appears to have broken my windows media player and MShearts (not great loses but annoying), so I cant open it anymore, unless I let it access the internet (I think)(which I choose not to).
I think it must be some kind of trojan. The places it was trying to access on the internet are:
Unticked fomr MSConfig (or deleted from registry...whatever) and deleting file from C:\Windows\System\ (not 32) doesnt seem to help. It just reappears when you restart.
I hadnt noticed that other file...Have deleted it and we shall see what happens now...


  Robesau 05:39 09 Oct 2003

Thanks SonicBlue and Base64UK! I thought I was the only one having trouble with gsb32.exe! I've had it for a few weeks now and had no luck finding any advice, until my Google search found your posts.

Earlier, I tried deleting the file and deleting any references to it in the Registry, but it came back the next day. I've just repeated the steps that Base64UK took. I'll let you know what happens!

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Moto G6 Play Review: First Look

iPad 9.7in (2018) review

Test : les écouteurs Bluetooth Honor xSport AM61