XP Pro - Add/Remove Programs?!

  Steve N 21:46 05 Jan 2003
  Steve N 21:46 05 Jan 2003

I have XP Pro with SP1 and most windows updates installed. I have just tried to Add/Remove Windows Components, and received the following message

setup was unable to open information file medctroc.inf

contact your system administrator. The specific error code is 0x2 at line 2011777033

Any random person have a clue why this file might be missing.

I also have a rather corrupt installation of Visual Studio .Net Enterprise Architect the setup file has some error. The only way I have been able to delete this off my system is by deleting the directory it is in and then using Norton System Works 'Windows Checkup' to remove the registry entries. It seems to work but does anyone know a way to completely remove it as I cannot reinstall it again without gettin the same error message!!

Any help much appreciated

  Chris777 21:52 05 Jan 2003

medctroc.inf is a file that's part of SP1, just one of many problems that SP1 and Microsoft's misleadingly titled "Critical updates" cause. Wipe & reload is what I'd suggest Steve, minus the Service pack, updates and Norton System Works.

  VoG™ 21:54 05 Jan 2003

medctroc.inf is supposed to contain a list of list of working TV Tuner cards.

Does this give you a clue?

  Steve N 22:02 05 Jan 2003

I did read that is was meant to have a list of working TV cards, but I really have no idea why it should be missing and why it should be needed when looking to add/remove windows components. I do have a Haupauge WinTV PCI FM TV Tuner. The drivers for this are pretty poor at least on my system anyway.

As for he wipe and reload! I have found through experience that this is the best way to rid XP of probs!!!! ;) why can't they just be little problems :(

  VoG™ 22:05 05 Jan 2003

Have you tried removing the card from device manager and rebooting? Windows will find it and, you never know, might restore the missing file.

  Steve N 22:19 05 Jan 2003

No such luck with that. It still can't find the file.

  Steve N 20:11 06 Jan 2003

OK fixed the Add/Remove Programs thing. Managed to find the .inf file in some temporary file and just copied it into Windows/Inf folder at it all works dandy now.

Anyone with idea on removing Visual Studio .NET completely?

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

iMac Pro review

See iconic duo Smith and Foulkes' epic animation for the BBC's Winter Olympics coverage

iMac Pro review

Idées cadeaux pour geeks et tech addicts