XP Help fails to work.....

  Preecey 00:31 23 Mar 2006

After a session of cleaning out in an effort to speed up XP, it was noticed that Help didn't work any more....there might be a brief flicker of an hourglass....but that's it! I had turned Help and Support off in the past (via msconfig) but having checked that it was back on, Help still does not work. Any attempt to directly open a 'compiled HTML Help file' is met with the message....'cannot open the file: mk:@MSITStore(etc). Anybody have any ideas......please!!


  beeuuem 01:11 23 Mar 2006

The solution, according to Microsoft, is click here

  Preecey 00:36 24 Mar 2006

I get the impression that something isn't quite right with a security update for XP that (well the PC did it actually....I had updates turned off as I thought it was safer....and then changed my mind) got downloaded a while ago. There was some stuff I read about a loss of Help HTML-based functionality, deliberately (I think) invoked by Microsoft because of vulnerability to something.....hacking perhaps...not sure.

I followed beeuuem's advice and checked the version of my hhctrl.ocx file, which is....5.2.3790.2453 (correct as far as I am able to ascertain). It currently lives in the Windows/System32 folder and possibly that's where it belongs...again, not sure. Microsoft's website is a complete nightmare....I find myself just going round and round in ever decreasing circles. Tried several others but they invariably take me back to Microsoft. I really would just like to understand at this point whether Bill Gates has 'killed' my Help or not!!! (XP SP2)

  skidzy 06:57 24 Mar 2006

This may help you,similar to beeuuem's link,just slightly different...could be the difference you need.Good luck
click here

  Preecey 00:13 28 Mar 2006

Another good 'point' there Skidzy. The situation as it now stands is.....get this....I have downloaded an older version of the hhctrl.ocx file from the Bubble website and...I used a recovery utility to try and find the old one, which I believe, was eliminated by some action or other....possibly an 'uninstall'.

Unfortunately the old one does not wish to be replaced. I know! Doesn't seem reasonable does it. I did try everything........but every time you go to replace the damn thing..you go through the procedure as detailed and....even though the regsvr32 procedure apparently achieves a positive result..the old version (5.2.3790.2453) is staring back out at me at the end. Every time the same result...almost spooky.

Funny thing is the Help facility is almost working. Some applications have Help....Word does, Excel does....but Explorer doesn't, other programs don't either. If you examine the 'properties' for the hhctrl.ocx file then there are a list of applications that should have Help....should be able to utilise XP Help....but half of them don't.

What to do? Anybody? The 'buy a new laptop' gag had already been offered....original offerings only.

I thankyou


This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Honor 9 Lite review

18 Best Adult Colouring In Books 2018

HomePod review

Les meilleures séries Netflix (2018)