XP Can't Find Any Programs

  Scottish1974 10:23 27 Jun 2007

Recently my desktop icons changed to the standard "unknown program" type.

If I try and run any program from the Start > All Programs menu I get "The file type does not have a program associated" error.

None of the .exe are working, same error.

I cannot access "System" from the Control Panel, same error message. No Control Panel icons are accessable.

I can't pass any stinger type file as they are .exe

PC's is patched, antivirus updated on startup, Ad-Aware loaded on startup, etc.

Can anybody help?

  johnnyrocker 10:35 27 Jun 2007

if xp try system restore?


  Scottish1974 10:47 27 Jun 2007

Hi Johnny,

I couldn't get to System Restore.

Start > Programs > Accesories > System Tools > System Restore came back with "The file type does not have a program associated" too. I tried to get to "Manage" of MyPC and the same.

What do you think?

  bof:) 10:54 27 Jun 2007

is it the same in safe Mode? Can you run any antivirus programs?

  bof:) 10:55 27 Jun 2007

sorry missed the line about virus checkers already on pc. I'm assuming they cannot be run.

  Scottish1974 11:00 27 Jun 2007

Safe Mode came back the same, won't run anything. I tried to get to the McAfee console, but same result.

I'm not having much luck......

  bof:) 11:02 27 Jun 2007

I've had a look in the search facility, this was given by VOG for what I think looks like a similar problem.

Try this

Start, Run, enter

sfc /scannow

and click OK. Insert the XP CD if prompted.


  PAC1 21:29 27 Jun 2007

Have you tried changing the file extension for system restore to get it to run as certain types of viruses/malware can prevent .exe files from running.

A .com extension will run the same as a .exe and can fool them into allowing them to run.

Go to folder options in control panel and deselect hide extensions of known file types.

The restore program is found in
c:\windows\system32\restore folder.
select rstrui.exe, right click it and click rename. Rename it to rstrui.com and then double click on it to run system restore and restore your computer to an earlier time.

This will hopefully remove the virus/malware that is causing your problem.

If this works you will then need to turn system restore off and then on again to remove all the restore points so you can not do not accidently restore at a later date back to the same problem.

Hope this helps


  VoG II 21:32 27 Jun 2007
  Scottish1974 09:09 28 Jun 2007

I can download the exefix_xp.com file, but it wont run either. Same error, "The file type does not have a program associated"

With sfc /scannow I get Windows can't find "sfc"

I can't access regedit either, same error. "The file type does not have a program associated"

I tried to do copy regedit.exe regedit.com, but get an error that windows can't find "copy".

Via windows explorer I tried to rename rstrui.exe to .com, but after renaming I get the same error, "The file type does not have a program associated"

To add insult to injury...

I can "open" a .xls from windows explorer and it will start Excel, same for Word, etc. But double clicking the excel.exe file doesn't work.

I can carry on via windows explorer, but can anybody tell me how to tidy this up without formatting/reinstalling?

Many thanks.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Samsung Galaxy S9 review

Wacom Cintiq Pro 24 and 32 review – hands-on

Best Mac video editors

Idées cadeaux pour geeks et tech addicts