WS_FTP PRO problems with ADSL Firewall Router

  Keith 21:23 17 Jan 2004

(this is also posted on Helproom forum - occurs to me that somebody here may be more likely to help)

I'm using a Netgear ADSL Firewall Router and
WS_FTP Pro v7.62 which seems unable to transfer files because of the router (it's OK with an ISDN dial-up). The transfer either hangs indefinitely or goes to 100% completion but with 0kb files, or only partial files, uploaded to the webserver. I've tried uploading the files as ASCII, binary and with and without passive mode.
Strangely, I do better with my old WS_FTP95 LE!

Have tried Ipswitch support but they will only support v8. Charming! Any ideas out there please? Thanks, Keith

  Forum Editor 01:01 19 Jan 2004

to allow your machine to act as a server when WSFTP runs?

  Keith 12:10 21 Jan 2004

Thanks for the advice, but how do I configure the router's firewall to act as a server? Keith

  Taran 12:36 21 Jan 2004

It depends on the model.

You should have a destruction manual or at least an installation leaflet that tells you how to access the control panel.

Normally you type in the IP address of the router to access its controls through a web browser interface.

Again, depending on the model you may have its manual either on floppy or CD.

Check out the documentation you got with the router or post its model number so one of us can source some information on it.


  Keith 13:43 21 Jan 2004

Thanks for quick response. I used the CD to get to the Router Settings (logged in as administrator) and checked Firewall Rules. The rules for Inbound and Outbound traffic are set to 'Default' - all inbound traffic is blocked and all outbound is allowed. The options exist to add/edit/delete rules.

Two interesting points: the encapsulation is set to PPPoA (ATM) rather than PPPoE (Ethernet). (I have an option to change this).

I checked that I can download files from websites to my PC and they work AOK, so it's just uploading that fails. Yet the Firewall Rules might suggest the reverse would happen!

Over to you, Taran. Keith

  Taran 14:05 21 Jan 2004

Your PPPo settings should be given by your ISP.

Mine requires PPPoA+NAT.

Usually if you get an installation CD the settings are input automatically or are in the documentation on the CD.

If your connection is working, I'd leave it that way for now.

If you can successfully use an earlier version of WS-FTP from the same system over broadband I'm not sure we should be looking to the firewall and altering any settings.

Can you confirm that you can FTP using an earlier version over your broadband connection, but that one particular version is causing the problem ?


  Taran 14:08 21 Jan 2004

Sorry, miss-typed.

I'm having a heck of a day today...

My router is also set to use ATM, which is as it should be.

Leave well alone if in doubt !

  Keith 16:05 21 Jan 2004

Yes - I can FTP with WS_FTP95 LE (a freebie download which I used for years). I am trying to get a later version that I purchased to work: WS_FTP Pro v7.62. Ipswitch will only support the latest version 8.

It seems so irrational to me that an old free version works when a later purchased version fails! It really niggles me!

Re PPPoA - OK, I'll not change anything. Perhaps the Firewall thing is a red herring anyway, but I have no idea what else could be causing the problem.

Just a bit more background: my wife and I share the router as she works from home (programming). There are no problems whatever on her PC, although she has no need ever to try FTP file transfers. My wife connects to a network in London via VPN (GRAS) with no trouble. The router was installed exactly as per instructions.

The internet connection is great in all other respects. It's just this strange problem in uploading files to websites (plural) via this version of WS_FTP.

Thanks for your interest. Keith

  Taran 16:42 21 Jan 2004

I didn't mean you to think that the Router/Firewall would not be the cause of this - it quite probably is.

Are you running any software firewalls in conjunction with your router ?

Wnidows XP built in firewall sometimes loves to jump on a third party FTP client program and snag its traffic.

Try a port scan at this URL and see what the results are: click here

Your router should have logging available so you could see if there are any listings for the WS-FTP program that is at fault here.

You may have to manually set up a port to allow it to function properly.

I have heard of some lag involved with certain Netgear routers, but this is probably clutching at straws.

Can you confirm the model of the router please ?

  Keith 17:07 21 Jan 2004

No, I have no software firewalls and checked that the Win XP firewall is turned off.

The router is a Netgear DG834 ADSL Firewall Router. Logging is currently turned off. I can go into settings and turn logging on if it may help the detective work.

I followed your link with the following results:
Files: VERY SECURE (the test was unable to connect with Netbios on my computer)

Ports: 0 ports open, 9 ports closed, 17 ports Stealth, 26 ports tested.

Cheers, Keith

"No unsolicited packets were received. No ping reply (IMCP echo) was received."

  Taran 17:44 21 Jan 2004

A quick search on the web suggests that a firmware upgrade has helped some people [but not others] and that adding FTP to the always allow list in the firewall made a difference.

Try searching yourself in Google, using these as your search queries, including the quote marks:



Sorry I can't be of more help. Got to go offline now for a few days.

Hope you get it sorted.


This thread is now locked and can not be replied to.

Elsewhere on IDG sites

iMac Pro review

Illustrator Charles Williams on how to create magazines and book covers

iMac Pro review

Les meilleures prises CPL (2018)