Wrong subnet mask

  Aristocatman 23:01 26 Nov 2003

I have a problem with net sharing on my small network. Computers are running XP Pro problem seems to be when the Host allocates IP addresses it allocates the wrong subnet mask to the client computers it allocates 255 255 255 255 instead of 255 255 255 0 I can manually set IP addresses but I can't find a means of setting sub net mask manually.
I have tried all the suggestions from help & loaded the network tools & was initially able to reset from command prompt but no longer works.
The nework seems very unstable I have had problems with 'can't find DNS server' & similar problems, it seems as soon as I cure one problem I get a new one in a couple of days. At the moment nothing will fix the problem seems to be terminal. Very frustrating! Help any ideas!!!???

  keith-236785 23:51 26 Nov 2003

right click on your network connection, CHOOSE PROPERTIES, click "internet protocol (TCP/IP)", click properties.

change the selector from "Obtain an IP address automatically" to "use the followin IP address"

then you should be able to enter your ip address, when you press enter, the subnet should be put in for you and SHOULD be 255,255,255,0

network IP addresses are normally for the main pc/server and 192.168.0.(2 to 255) for the clients. all with a subnet mask of 255,255,255,0.

good luck.

Do check the TCP/IP settings of the DHCP server that you are using.

For a private network it normally is with the subnet of

If the subnet setting is wrong on the server then it will pass that same subnet mask to all of its clients.

  Aristocatman 18:57 27 Nov 2003

Thanks for the replies -I have tried all the suggestions including manual settings I have used the various tools in the toolkit with some success but they only seem to work once everything is fine for a few days then it falls over, I can see the connection - network & internet in the task bar but it doesn't work. Problem definitely seems to be the subnet mask being different on the host & clients, the IP addresses are fine. I am beginning to think I will wait until February when we get broadband & I'll get a router!

Until February (you lucky....) I would suggest that you forget about the DHCP and set them up manually as suggested by paperman27, (reponse 1).

If you are using ICS then make sure that that computer is set to the and each of the other computers has a unique number in the same range.

Best wishes


  Aristocatman 16:09 28 Nov 2003

Thanks whisperer but sadly I have already tried manual setting & checked that they are in the same range - if only life was that easy!
We got a date for broadband by putting up posters locally to get people to register with BT & finally got enough we're pretty rural here - no cable so you can get it if you get enough people registering.

  alcudia 16:18 28 Nov 2003

Same here. Poster campaign to get registrations in. Being activated in Feb.

You don't live near me do you?

Incidentally on my network all the IP's start with 172 and all the subnets are 255 255 0 0

  Aristocatman 18:33 28 Nov 2003

Maybe I live in Mumbles S Wales, roll on February.

  recap 18:52 28 Nov 2003

Run a `Command Prompt` and type in the following: ipconfig

Post back your results.

  recap 18:58 28 Nov 2003

One other thing Aristocatman, could you post the IP address's of your machines. The subnet mask you have posted is a class A range of address's.

  Aristocatman 19:27 28 Nov 2003

Well would you believe it I just tried to connect to the internet on the client PC & it worked! you guys haven't been waving magic wands have you?
out of interest
ipconfig returned:
Ethernet adapter Local Area Connection:
Connection-specific DNS Suffix . :
Ip Address......................
Subnet Mask.....................
Default gateway................. :
PPP adapter Demon G5:
Connection-Specific DNS Suffix . :
IP Address...................... :
Subnet Mask..................... :
Default Gateway................. :

On the client PC
Ethernet Adapter Local Area Connection
Connection-specific DNS Suffix . :mshome.net
Ip Address...................... :
Subnet mask..................... :
Default Gateway................. :
& it all works fine!

I have been switching all the PC's off recently instead of leaving them running but up until just now internet sharing was not working, very odd!

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Sea of Thieves Review

Dell Canvas review: the cheap Wacom Cintiq alternative

How to use iMovie for Mac, tips and more

Comment filmer l’écran d’un iPhone ?