Write protected mp3 player

  edenworkshops 13:32 07 Sep 2008


I have an mp3 player which, when I try to delete or import files, tells me the disk is write protected and I cannot add or delete files.

I have looked around on the net and seen advice such as going into the properties of the file, but this did not work.

Can anyone suggest a fix for this please.

Thank you


  Fruit Bat /\0/\ 15:24 07 Sep 2008

Several reasons why this can happen on a USB device

1. corrupt file on the device
format the device or run Kill disk (remember this will wipe everything on the device).

2. the device has a write protect or hold switch
move switch to correct posititon.

3. Incorrect setting in windows Storage Device Policies
do a "regedit" for StorageDevicePolicies key.
. Get into the Registry - Press Start -> Run, enter regedit, press Ok
. Click on My Computer. Then press File -> Export, give some file name to backup the registry. Just incase you ever need to rollback.
. Navigate to HKEY_LOCAL_MACHINE/SYSTEM/CurrentControlSet/Control/StorageDevicePolicies
. In the right pane select "writeprotect"
. RESET the value to '0'

Repeat the same for ControlSet001 and ControlSet002 incase they exist.

Now plug in your USB drives and it should work. Else just reboot the machine and try. This has worked on most of the machines on which I tried.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Dell XPS 13 9370 (2018) review

No need to scan sketches into your computer with Moleskine's new smart pen

How to use 3D Touch on iPhone

Comment importer des contacts d’un iPhone à un autre iPhone ?