work laptop will not connect to home wireless

  elp99jcm 13:45 24 Jan 2010

I have a work laptop which is connected on a wired network at work and, until last week, worked flawlessly when I brought it home and used it on my home wireless network (no VPN involved).

Last week I got the "Limited or no connectivity" message when connecting to my home wireless and a 169.XXX IP address. Using a wired connection direct to the wireless router port works fine. My other, non-work devices connect fine wirelessly (they are all Linux based).

I have read a large number of posts and tried all the potential fixes but have had no success so decided to post the problem. A key thing I have done is tried a different USB wireless dongle, which uses separate drivers and proprietary wireless config software so I am certain this is software related, not hardware.

Below are further details on the setup and current things I have tried.

Any advice would be much appreciated.

Laptop HP 6910p, Windows XP SP2, Intel 4965AGN Wireless card
Router DLink DIR-635

Things I've tried:

* Checked the WPA key (I have tried with no encryption also (see below).
* Turning off windows firewall (only firewall installed).
* Router and laptop are next to each other, so no signal strength problems.
* ipconfig /renew and /release and /flushdns etc.
* Updated drivers for ethernet, wireless. Updated firmware on router.
* Reset router to factory default
* Installed WPA2 update to XP.
* Tried various encryption including no encryption on router.
* Tried USB wireless card (which works fine in other machine) with latest drivers and this uses its own wireless config. Exactly the same problem with this.
* Tried 'repair' connection option.
* Tried winsockfix utility.
* Wired connection DOES work fine.
* Disabling dhcp and configuring IP and DNS statically. This connects sucessfully with excellent signal. I can ping the IP address and loopback address but cannot even ping the router or anything externally.
* Replaced tcip.sys
* Scanned for virus/spyware

It seems the laptop just cannot talk to the router at all. But why? And why now suddenly? Even when connected using staic config, I cannot ping or view the router page in a browser.

The reason I stressed that this is a work laptop is that they may have made some changes which I am unaware of. I did try a restore back to a previous date but this has not solved the problem. However, I was not sure the restore worked correctly (if anyone thinks this is important I'll elaborate but I am conscious this post is getting long anyway).

My work IT department 'Do not support home wireless connectivity issues', which is perhaps not surprising.

Any advice would be much appreciated.

  Jollyjohn 18:50 24 Jan 2010

Try looking in CONTROL PANEL - ADMINISTRATIVE TOOLS - SERVICES - and look for "Windows Zero wireless" service This should be running and should be set to run automatically.

Also in Network connections if you right click the wireless connection you will get a list of preffered wireless networks - delete them all and reboot and try connecting again.

  elp99jcm 21:29 25 Jan 2010

Thanks for your response. "Windows Zero Wireless" is running. It was set as manual and I have changed to automatic. I have also deleted all connections, rebooted and the problem persists.

Based on another thread somewhere I went through all the services and they are running as expected.

I have down two things more to try and isolate the problem:

(a) Went to a colleagues house and tried to connect to a different router. This also failed, although not with the 'limited or no connectivity'. It just kept trying to connect to the router then stopping, then trying again and then giving up.

(b) Booted into a Linux Live CD. This made me happy as I am a Linux person at heart. The wireless worked flawlessly.

So although this hasn't helped, it has confirmed a Windows software issue.

  T0SH 15:32 28 Jan 2010

Thalk to the IT department at work, your laptop is most likely set up to log on to a Domain, if so this can cause the type of problems you are having

Cheers HC

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Samsung Galaxy S9 review

Wacom Cintiq Pro 24 and 32 review – hands-on

When is the next Apple event?

Gmail : comment annuler l’envoi d’un e-mail ?