WMP 10 Not Detecting CD/DVD Burner

  [DELETED] 19:42 13 May 2006


Over the past month or so I've been having problems burning CD's/DVD's using Windows Media Player 10 and/or Ulead DVD Movie Factory 4 and/or Nero 6. When I click on the Burn tab in WMP 10 it shows the following message: "No CD or DVD burner has been detected. Press F5 to refresh the player." I have pressed F5 over and over which makes no difference. I then tried to burn a CD using Nero and get a message asking me to insert a blank disc into the drive even though there is one already in. I use TDK CD-R's and DVD-RW's. When using Ulead DVD Movie Factory 4 to burn DVD's it gets through the file-conversion process but when it comes to actually burning it also displays an error.

Now I know it's not a hardware fault as I previously had a Sony DW-Q28A drive which had exactly the same problems so I replaced it with my current Pioneer DVR-111D drive. I have tried uninstalling/reinstalling Nero and Ulead and Media Player and restoring my computer to an earlier to time and none of this works which to me suggests it may be a registry problem in XP. I have all the latest driver updates for all the software and from Windows Update. Another thing that is occurring is that when I insert a CD or any type, for example and audio CD instead of coming up with the usual box asking you which program to use to play the files, it just shows the folder and what files it contains. Which means I have to select all the songs and right-click them to play them.

I have searched the net and spoke to a few friends of mine who have exactly the same problem but still can't find a solution. Short of phoning Microsoft's premium-rate helpine (which costs over £1 a minute) I don't know what else to do.

Surely someone must have an answer to this problem? Thank you in advance for any help you can give. P.S. Sorry for the long post.

  [DELETED] 20:45 13 May 2006

Have you tried this click here
It may be you have uninstalled a codec by mistake.

Good luck

  [DELETED] 15:41 14 May 2006

Thanks for the reply Skidzy, I downloaded and installed the codecs from the link you provided but this made no difference to WMP 10 recognising my DVD writer. I can burn DVD's using Ulead however as it turned out that the file I was trying to burn was an unsupported format so I converted it to mpeg and had no further problems. I have also found that I can burn audio CD's using my Creative Media Source Organiser software that was provided with my Soundblaster Audigy 2 soundcard. But this is very slow as it checks to find the blank CD first which takes roughly 1 minute, then when I click to start burning it checks again for the same CD and eventually starts the burning process.

I have come to the conclusion that my problem must be somewhere in my registry as there is no other explanation for why Media Player can't find my CD/DVD drives, why it won't burn using Nero and why it won't automatically play CD's without me selecting them in a folder first. I have wasted much of today trying to sort this problem and still have no luck so I may have to dip my hand in my pocket and fork out around 30 quid to pay for a one-off phone call to Microsoft to see if they have any ideas.

  [DELETED] 17:29 14 May 2006

Try this to tidy up your registry click here
And this click here this tool has a function called issues...this may help out.Other funtions are availble with the ccleaner also.

Good luck

  [DELETED] 10:04 15 May 2006

Thanks again Skidzy. I downloaded both programs you mentioned and they both found various problems which I then fixed. From the list of problems they showed, none seemed to be specifically causing a problem for my DVD writer. However when I go into Media Player now it does recognise that there's a CD drive present and I then select some files to burn but it just says: "There are no items on the CD" every time I click Start Burn. I clicked on the little red tick above the Cd Drive list to display the properties and settings and "Enable CD recording on this drive" is ticked but it's still not burning for some unknown reason. Any suggestions?

Thanks very much for your help so far.

  realist 11:47 15 May 2006

I too have had problems with WMP10 and burning to disc where disc is not "seen". I have to reboot and then it (sometimes) works. I think the prog is very buggy as quite often the sound mutes itself and I have to do a system restore to get it back.

  [DELETED] 19:41 15 May 2006

Well I have to agree with you Realist, I think it's a bit hit and miss. As if by magic I managed to burn a CD just this minute using Media Player. Having said that, it does appear to be back to it's old tricks as now when I click on Burn it says it can't find my CD drive again. I'm sure after numerous reboots I could get it going again but to be honest I don't think I can be bothered wasting any more of my time over this. I'm just gonna get Nero instead probably and hope that works ok. The main thing I use Media Player for now is listening to CD's and synchronising it with my MP3 player.

I just find it starnge that so many people seem to be having exactly the same problem all of a sudden after months of it working fine.

Thanks very much for everyone's help, I'll leave this post as unresolved just in case someone finds a solution.

  [DELETED] 19:56 15 May 2006

You have tried the k-lite codec pack and still having problems,maybe try this and see if it throws anything up click here

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

How to watch the World Cup for free on TV and online

Meet Superfiction, the little design studio with a load of character

Best Mac buying guide 2018

Comment résoudre les problèmes de connexion internet d’un iPhone ?