Wireless Problem - Cannot Connect with Primary DNS

  pboy1981 13:30 16 Aug 2010


I'm trying to give my friend access to our Wireless service. Whenever I've done this on any other laptop before, it's been really easy and automatically finds the router.

My friends laptop finds the router and when looking at the status it seems to be talking to the router, but does not connect to the internet.

The message returned is 'Cannot Communicate with Primary DNS Server('.

I've tried lots of different things, looked at all the settings, re-started the router and still get this message. There is never any problem with the other 3 laptops we use at home.

Can anyone help ? Operating System is Widows Vista. It's driving me nuts!!!!

Many thanks,

pboy :o)

  mgmcc 13:51 16 Aug 2010

Go into the Services window ("Start > Run", type SERVICES.MSC and click OK), then scroll down to the DNS Client entry. Double click it to open its Properties sheet and check that the service is "Started" and that its Startup Type is "Automatic".

Also, it wouldn't do any harm to flush the DNS cache. Open a Command Prompt window ("Start > Run", type CMD and click OK) and, at the prompt, type...


...and press Enter.

I'm assuming that the Wireless Network Adapter in Laptop in question is compatible with the type of encryption set up in the Router (WPA, WPA2 etc)?

  pboy1981 17:01 16 Aug 2010


I tried what you suggested and still hasn't resolved anything.

Both wireless network adapter and Router are compatible as my friend has the same laptop which works with no problems.

Would you or anyone, have any other advice ?



  iscanut 17:15 16 Aug 2010

There seem to be a few posting elsewhere re this problem. If you Google "Cannot Communicate with Primary DNS Server" then have a look at the postings. May help !

  onthelimit 17:18 16 Aug 2010

This thread click here cured a similar problem.

  northumbria61 17:21 16 Aug 2010

Try this -


You should see a WIRELESS NETWORK CONNECTION in there. Right-Click on it and click PROPERTIES.
Click Properties
Click the DNS tab
Click ADD
Type the IP Address
Click ok on everything and run that repair again just to make sure it takes the new info.

  pboy1981 17:52 16 Aug 2010

Hi northumbria61,

I'm using Vista, so the path you've described to enable me to add the DNS details doesn't work for me.

Would you know how I access this on Vista ?



  MAJ 18:30 16 Aug 2010

northumbria61 copied and pasted the XP solution, for Vista, go to Control Panel > Network and Sharing Centre, click on the "Manage Network Connections" link (on the left). Right-click on your mate's wireless connection and choose Properties > Networking tab, select the Internet Protocol Version 4 entry in the list and click the Properties button. Make sure the "Obtain an IP address automatically" and the "Obtain DNS server address automatically" options are ticked. Try that first. If it doesn't work go back to that part again and click the "Advanced" button followed by the DNS tab and continue on as in northumbria61's post.

  pboy1981 19:54 16 Aug 2010

MAJ excellent work. Worked a treat !!!

Thanks everyone for your help :o)

  MAJ 20:23 16 Aug 2010

Glad you got it sorted, pboy1981.

  zanny1 13:53 26 Aug 2010

I am having exactly the same problem with my Home Vista running in Sony VGN-NR21J/S. The wireless signal from my new Dynamode BR411NT router is strong and shown connected on my laptop. However when I open up the Internet Explorer, it said cannot communicate with Primary DNS Server( I followed the instructions as given by northumbria61 and MAJ. First add the address in IPv4 - that did not work;then on IPv6. I still get the same message. I have been going round and round in circles trying to resolve this. Please help,anyone?

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Honor 9 Lite review

HomePod review

Les meilleurs logiciels de montage vidéo gratuits (2018)