Wireless to LAN ICS

  breider 18:20 18 Dec 2005
Locked

I am trying to share a wireless connection from my laptop to my desktop w/ XP ICS and a crossover cable but can't seem to get it to work.

In My Network Places, I can access shared files on both computers but the desktop can not connect to the internet. The LAN connection displays the "Limited or no connectivity" message. The IP automatically assigned to the LAN on the laptop is 169.254.137.101 and 169.254.31.203 on the desktop. Both have subnet mask 255.255.0.0.

I've seen similar posts on the topic and have tried the following: reinstalling both drivers on laptop (wireless and LAN), setting static IP's (192.168.0.1 and 192.168.0.2 to laptop and desktop respectively), reconfiguring home office network settings and repairing/restarting numerous times. I also tried using WinsockXPFix and a windows hotfix (Update for Windows XP Service Pack 2 (KB884020)) after which I needed to again reinstall my wireless card.

Any help will be greatly appreciated.

-Drew

  mgmcc 21:14 18 Dec 2005

At the moment both network adapters are set to get their IP address automatically, but there is no DHCP server from which to get them. Windows has therefore allocated default APIPA (Automatic Private IP Addressing) addresses in the 169.254 range which won't let you internet share and usually won't let you access shared files either.

If your laptop is connected to the internet with a Wireless connection, you need to enable "Internet Connection Sharing" on *that* connection in the Network Connections folder.

To enable “Internet Connection Sharing” in Windows XP, open the Network Connections folder, right click the actual internet connection (modem connection), select Properties and then the Advanced tab. Tick the box “Allow other network users...etc”.

When you enable "ICS", your Local Area Connection will automaticlly be configured with the fixed IP address 192.168.0.1 and subnet mask 255.255.255.0. It is important that this is done as part of the ICS setup, rather than you entering the address manually. This process also enables the "Host" PC as a DHCP server to allocate the addresses to the "Client" PC, which should get an address in the same 192.168.0.xxx range.

If you are running software firewalls, the IP addresses of the networked PCs must be put into its "trusted" area to allow them to communicate with one another. Also, if you run the Zone Alarm firewall in your “host” PC, the Internet Zone Security level must be reduced from High to Medium or “ICS” traffic will be blocked.

  breider 02:24 19 Dec 2005

Sorry, I should've meantioned I already have the wireless connection shared. The only time it was not shared during all the trials I meantioned before was when I had the IPs set to static. Also, I have had all firewalls disabled throughout the ordeal.

  breider 07:56 19 Dec 2005

Got bored and started messing around w/ it again and got it fixed. I set my desktop to obtain IP address automatically and had the wireless connection shared like normal, but this time set the LAN on my laptop to use the IP 192.168.0.2 and the subnet mask 255.255.255.0.

Can anybody give an explaination as to why this solved it?

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

AMD Radeon Adrenalin release date, new features, compatible graphics cards

8 brilliant character artists speaking at Pictoplasma 2018

iMac Pro release date, UK price & specs

Football : comment regarder la Ligue 1 en direct ?