Wireless connectiom won't find internet

  Pineman100 13:00 19 Jul 2008

My daughter runs Vista on her laptop and connects to the internet wirelessly via a BT Home Hub. She is now trying to connect her older desktop (runs XP) to the internet through the same Home Hub with a USB Belkin wireless adaptor (latest type, 802.11n).

She's successfully installed the adaptor, which is finding the wireless network successfully. But it stubbornly refuses to connect the the internet.

I've check the IP address and subnet mask and they're both listed as

We've even tried setting up the connection with a one-time ethernet connection to the hub, but it still won't connect to the internet.

Anyone got any suggestions, please?

  Pineman100 14:28 19 Jul 2008


  kidsis 14:52 19 Jul 2008

often caused by hardware problem (in this case the usb adaptor), or perhaps driver problems. As the adaptor finds the wireless network maybe we can rule this out? Have you looked in device manager to see if there is a yellow question mark against the device. I see also it is a 802.11n, is the home hub ok to take n devices?
Do you get the ip address via dhcp or is it static? A firewall can often cause connection problems. Also is the hub set up to use mac address filtering?

  Pineman100 15:29 19 Jul 2008

You make some valid points.

I've checked Device Manager, and the adaptor is reported as working properly. Yes, it's an "n" adaptor, but I thought all 802.11 devices were backward compatible with earlier versions. Do you know whether this is the case?

I assumed the fact that the adaptor is finding the wireless network confirmed compatability between the adaptor and the router. Do you think I'm wrong?

No, the hub isn't filtering MAC addresses - sorry, I should have mentioned that above.

  Pineman100 16:26 19 Jul 2008


  Pineman100 19:05 21 Jul 2008


  woodchip 19:10 21 Jul 2008

You need to get the Encryption key settings from the router as well as SSID to put into the Adapter Software, There should be a icon in the system tray for you to open adapter software, just double click it

  Pineman100 19:21 21 Jul 2008

I have entered both those bits of information, direct from BT's notification letter - and I'm sure I did so correctly. They worked for my daughter's computer, but this one stubbornly refuses to connect.

As I said, it is "seeing" the network (ie: listing it on the wireless networks list) but it just won't connect to the internet.

  Fruit Bat /\0/\ 20:45 21 Jul 2008

IE - tools - connections tab - lan settings - Automatic configuration - untick both boxes

  woodchip 23:04 21 Jul 2008

As I said have you put the settings into the USB adapter Software

  woodchip 23:06 21 Jul 2008

Have in fact loaded the Drivers off the CD that you got with the adapter? as this allows you to load the settings to where they should be in the adapters software

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Samsung Galaxy S9 review

Wacom Cintiq Pro 24 and 32 review – hands-on

When is the next Apple event?

Qu’est-ce qu’Amazon Prime ?