Wireless adapter no longer working after h/ware re-install

  davepatrickl 20:48 22 Jul 2013

I have replaced by HDD with an SSD on my dell studio 1537 laptop. Everything else has worked fine but I have been unable to get wireless working. The internal wireless card (labelled in order as ‘Intel WiFi Link 5100 (802.11 a/b/g/n 1X2) 1/2 MiniCard European) doesn’t appear to be recognised and when I have downloaded the relevant driver, I got the "No compatible hardware found" error. I have also run the Dell System Detect and other updates and…nothing.

The wireless adapter doesn’t show in the Device Manager, however, under Other devices, a ‘Network Controller’ is visible with a yellow error flag on this. I have right clicked and tried to update drivers but this hasn’t worked.

Other things to note – the wireless switch on the side of my laptop is turned to on. I also didn’t go near the wireless card when replacing the hard drive and this worked perfectly well before. I’ve checked the BIOS to check if the problem is there and the current Wireless readings are:

• Bluetooth Control [Enabled] • WWAN Control [Enabled] • Wi-Fi Control [Enabled] • Wireless switch [ALL] • WiFi-Catcher [Enabled}

  Chronos the 2nd 08:37 23 Jul 2013

Try installing this driver and hopefully this will get rid of the Network controller driver error and hopefully resolve your problem.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

HTC U12 Plus review: Hands-on

Best Android emulators for Mac

TV & Streaming : comment regarder Roland Garros ?