Wirekess Internet Connection - Media disconnected

  chrisc912 21:20 26 Oct 2007


My laptop is running Windows XP and was working fine the other day. When I turned it on today I noticed that it did not connect to my wireless network.

I have tried manually connecting to the network, but it doesn't connect. I can view a list of wireless networks, but I can't seem to connect.

I have tried resetting the router, disabling/re-enabling the network adaptor, removing and then re-adding the network, but had no success with any of them.

When I type ipconfig /all into the command line I get the following:

Windows IP Configuration

Host Name . . . . . . . . . . . . : laptop

Primary Dns Suffix . . . . . . . :

Node Type . . . . . . . . . . . . : Broadcast

IP Routing Enabled. . . . . . . . : No

WINS Proxy Enabled. . . . . . . . : No

Ethernet adapter Wireless Network Connection:

Media State . . . . . . . . . . . : Media disconnected

Description . . . . . . . . . . . : Intel(R) PRO/Wireless 2200BG Network Connection

Physical Address. . . . . . . . . : 00-0E-35-CE-C8-52

Ethernet adapter Local Area Connection:

Media State . . . . . . . . . . . : Media disconnected

Description . . . . . . . . . . . : Realtek RTL8139/810x Family Fast Ethernet NIC

Physical Address. . . . . . . . . : 00-C0-9F-70-8A-6C

Does anyone have any ideas as to what might be wrong, and how I would go about fixing the problem?

Many Thanks,


  chrisc912 21:21 26 Oct 2007

Just noticed the typo - should say "Wireless Internet Connection Media disconnected"

  Ashrich 21:33 26 Oct 2007

This means the wireless adapter is either switched off from a hardware switch or it is turned off in software , have a look in device manager / network adapters / advanced , and see if it can be turned on or off from there .


  Ashrich 21:43 26 Oct 2007

Should have read the whole thread properly , I see you can view networks so it must be enabled , another thing to try is a TCP/IP reset , go to start/run , type in CMD and press enter , in the command box type in ..netsh int ip reset reset.log and press enter , on the next line you can reset the Winsock , type in ..netsh winsock reset catalog and press enter , try those .


  chrisc912 22:14 26 Oct 2007

I've just tried both of those commands, restarted the PC, but I still can't connect to the network.

  Ashrich 23:45 26 Oct 2007

Have you tried temporarily disabling your firewall to see if that makes any difference ? Can you connect the PC by ethernet cable to the router and get on the internet that way ? When it fails to connect what message do you get ie. Limited or no connectivity or what ? Have you tried connecting without any wireless security turned on ( again , just to test ) .


  chrisc912 09:09 27 Oct 2007

Thanks for your suggestions.

I've tried disabling the firewall and connecting to the network, but no luck.

There isn't an error message as such, it tries to connect, a pop-up box which says "waiting for the network" is displayed and after a minute or so closes without connecting.

I have tried connecting to the internet using an ethernet connection and this also doesn't work. As you can see from the ipconfig output above, it is also showing "media disconnected". I can connect to my router via its ip address this way, but that's all.


  Ashrich 22:49 27 Oct 2007

I think I'd next try updating the drivers for the card , go to the card makers web site , not the laptop makers , and download the latest driver , unzip it to a empty folder and go to device manager/network adapters/wireless adapter/driver , click on " update driver , don't let Windows connect to the internet , point it to the folder you created and they can load from there , see if that helps .
One more thing , are you letting Windows manage your connection , or the 3rd party software supplied with the adapter ?


  Ashrich 23:02 27 Oct 2007

If neither wireless or LAN are working it still sounds like a broken Winsock or TCP/IP stack , have you removed any programs or had any spyware removed recently ( just before this happened ) , try this as the command line version didn't do anything .....click here, it might do the trick .


  chrisc912 23:03 27 Oct 2007

I've just got the latest drivers from the manufacturers site, installed them, but I'm still having the same problem.

I'm letting Windows manage the connection. I don't have any other software installed for doing this.


  chrisc912 23:11 27 Oct 2007

I've tried the Winsock XP program, but it hasn't fixed the problem.

I had McAfee Internet Security Suite 2007 (just the antivirus) installed. The problem started just after I removed it. I decided to switch to AVG as it doesn't slow my laptop down as much.

I hadn't thought about that until you've just mentioned it. Do you think that removing it could have something to do with the problem?

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Dell XPS 13 9370 (2018) review

No need to scan sketches into your computer with Moleskine's new smart pen

How to use 3D Touch on iPhone

Comment importer des contacts d’un iPhone à un autre iPhone ?