WinXP System Restore Failure

  pepe 15:06 20 Apr 2003
Locked

I am running WinXP Home. When I try to run System Restore I get the following error messages.

If I try to run through: Start\Prograns\Accessories\System Tools\System Restore

"An exception occured while trying to run "Shell32.dll, control_run dll "C:\windows\system32\sysdm.cpl", system"

If I try through right click My Computer\Properties\Systen Restore Tab

"Run a dll as an app has encountered a problem and needs to close"

I have sent both error messages to MS, and searched the MS Knowledge Base, as well as Google without success. I have tried re-installing SP1, also without success.

Has anybody any ideas, Thanks in advance.

  Elrond 15:18 20 Apr 2003

Do a repair of winXP would be my next step

  powerless 15:40 20 Apr 2003

Start > Run > Copy and Paste:

%SystemRoot%\System32\restore\rstrui.exe

Then click "ok". This is another way to launch system restore.

Failing that...

Start > Run > Copy and Paste:

SFC /SCANNOW

Click "ok" and have your XP CD in the drive when you do this.

  pepe 15:54 20 Apr 2003

Powerless

Have tried both, still no joy, same error message.

Elrond

Yes would probably work, but a bit drastic at the moment as it means re-installing SP1, and all hotfixes from MS Windows Update again, apart from System Restore not working my computer is otherwise stable.

Any other ideas?

  graham√ 16:04 20 Apr 2003

Do you need SP1 and the hotfixes? Also, if your PC is stable it may be better to leave it as is, just set a restore point. But then, what do I know? I hear you cry! :-)

  pepe 17:03 20 Apr 2003

Graham

Can't set a restore point as I can't start System Restore, regarding the SP1 and hotfixes, probably not as I believe one of these caused the problem in the first place. Oh well...........

  TOPCAT® 18:13 20 Apr 2003
  Happy1 18:14 20 Apr 2003

I was just reading a post from Graham which was posted at 15.21 titled Microsoft security patch. I looked on vibrantmedia site. Problems with security patch Q811493. Problems same as yours in another posting causing blank system restore points. It says delete this hotfix and all should be well. I may have to do same as I have this Hotfix. Have not yet checked in system restore, as I have just read about it. Im waffling now.Bye..

  pepe 22:13 21 Apr 2003

Thanks to all those that responded, and apologies for the delay in getting back. Well I tried this and I tried that, I even tried the other, sad to say not even that worked, and I am fresh back from a re-format and clean re-install, and all is well now (fingers crossed).

Thanks again to those who took the time out to respond

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

AMD Radeon Adrenalin release date, new features, compatible graphics cards

8 brilliant character artists speaking at Pictoplasma 2018

iMac Pro release date, UK price & specs

Football : comment regarder la Ligue 1 en direct ?