Winsock Problem (I think)

  wackosteve 23:49 18 Nov 2007

This is a follow up to my previous post. I cannot access the net but can use MSN, online poker and Outlook. I can access all thes program even when IE wont work.

I have run all programs and repaired my winsock etc but everytime I reboot the same problem appears.

Windows XP help says I have a winsock catalog error and needs to reboot. even when it reboots it still wont work.

Does anyone know how I can fix thi please. I d alot of business on my laptop but now i am close to throing it out the window.

is there somewhere online i can just re install and check my internet problems

many thanks

  brundle 23:52 18 Nov 2007

I realise the link suggests a Mac related answer, but it's for Windows; click here

  wackosteve 00:35 19 Nov 2007

cheers for that brundle.

I have done all that several times but still when i reboot i get the same problems

  brundle 20:41 19 Nov 2007

Does the same occur if you use Safe Mode With Networking ? I mean, after a `repair`?

  wackosteve 20:50 19 Nov 2007

I cant access the net from safe mode.

i need to somehow repair all the programs that run on start up.

Gonna install xp again I think.???

Would that solve the problem??


  brundle 21:00 19 Nov 2007

"I cant access the net from safe mode." > wireless?

Re-installing is quite likely to solve it, but if you put back whatever is repeatedly damaging the Winsock setup you'll be back where you started.

While the system is working, access a command prompt, type

netsh winsock show catalog > "%userprofile%\desktop\working.txt"

When the machine reports the error do the same again before you reboot, but this time rename the file

netsh winsock show catalog > "%userprofile%\desktop\not_working.txt"

Compare the two text files (both on your desktop).

  wackosteve 21:15 19 Nov 2007

cheers for your help.

you are saving the family from getting an ear bashing because it really is geting to me now.

I have found this on the microsoft website concerning winsock catalog. How do I know if I am running SP2?? also, how do test each 3rd party program.......???

To resolve this problem if you are running Microsoft Windows XP Service Pack 2 (SP2), follow these steps:1. Rebuild the Winsock LSP chain. To do this, follow these steps:a. Log on to the Microsoft Windows XP workstation as an administrator.
b. Click Start, click Run, type cmd, and then click OK.
c. At the command prompt, type the following, and then press ENTER:
netsh Winsock reset
When the program is finished, you will receive the following message:
Successfully reset the Winsock Catalog. You must restart the machine in order to complete the reset.
If you receive this message, go to step 1d.

If you are not logged in as an administrator, you will receive the following error message:
Unable to reset the Winsock Catalog. Access is denied.
If you receive this message, log off the computer, and then log back on by using an account with Administrator access. Typically, the first user account that was created has Administrator access. Then, repeat steps 1b and 1c.
d. Restart your computer.

2. Test each of your third-party programs that are known to use LSPs.
3. Reinstall any malfunctioning third-party programs that are known to use LSPs

  skidzy 21:16 19 Nov 2007

Do you have previous link to the problems to see what you have tried.

Reason i ask,i had a similar problem for months and all help here and google proved fruitless.

The answer was in the routers configuration for me.

I had use of anything that did not need IE,the boys game servers and msn but no browers.

Though possibly not related to your problem,i would check out the routers configuration.

Assuming your using a router of course.

  wackosteve 21:21 19 Nov 2007

cheerrs for that

that sounds like the exact problem i am having.

BT have checked the connection and say it is working correctly.

How did you solve it mate?

I will try anything now.........

  skidzy 21:26 19 Nov 2007

Firstly have you tried rebooting the router.

Remove the power for a few seconds and try again,if no joy enter the routers configuration and look for the idle time and set this to a high number.

Can you post the routers make and model.

Possibly a few settings need altering if im correct.

  wackosteve 21:27 19 Nov 2007

am i right in thinking that the router is my BT home Hub........

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Honor 9 Lite review

18 Best Adult Colouring In Books 2018

HomePod review

Les meilleures séries Netflix (2018)