Windows XP unable to start.

  peterleemaxwell 15:48 17 Sep 2013

I'm hoping someone can help me. I visited my Brother-in-law who's laptop win not start. It states the 'Winnet.dll' file is missing. This appears even when safe mode is selected. We are stuck. He has no windows disc just a rescue disc that will format and reset everything. Is there anyway it will start? Thanks.

  Fruit Bat /\0/\ 16:21 17 Sep 2013

CAn you actually get into safemode?

If so STart - Run - type

sfc /scannow

press OK

let windows scan for and replace missing or corrupt windows files, this will take some time.

  wee eddie 16:50 17 Sep 2013

I love "this will take some time"

Depending on Disk Size ~ 2 to 16 hours are not unusual and often possible

  peterleemaxwell 19:03 17 Sep 2013

Hi Fruit Bat /\0/\, Cannot get into safe mode as the missing file warning flags up and when 'OK' is pressed closes down. I will try another XP disc to see if this will 'repair' but I seem to have done this a few years ago on my own old PC and because it was a different copy from the one on the PC, it wouldn't work. I give it a go as I will try everything.

  woodchip 19:37 17 Sep 2013

put the Disc in the drive then tapF8 as it starts see if it will go to safe mode or try Last Known Good Config

  woodchip 19:40 17 Sep 2013

PS another way would be to choose Comand Prompt from List when trying F8 then Extract the file from Cab File in the i386 folder under Windows folder. If you know how to do it.

  woodchip 19:50 17 Sep 2013

Sorry just looked on my XP laptop, the file you are looking for is under C:\i386\Wininet.dll File Size 294kb should be placed in the C:\Windows\System32 FOLDER by Copy Paste.

NOT Winnet.dll

  peterleemaxwell 21:03 23 Sep 2013

After trying to fix my brother-in-laws laptop PC via phone I now have it here at my house. I placed a windows XP CD in the drive after it continually froze on the logo screen. Tried safe mode, and last known..... to no avail. After pressing 'R' it then requires a admin password. How do I get pass this as after three attempts it asks for a restart. Is there anything I can do or are we doomed and a format is in order? Obviously this would fix things but I would much to prefer to repair it if possible as there are files and the set-up when running OK. Any help appreciated.

  bumpkin 22:05 23 Sep 2013

I am sure you would have tried this but just in case. Ask your brother in law if he has set a password, if so what is it. Can you continue without entering a pasword just leaving it blank, look for the "next" or "continue" tab. If that still fails try "admin" is the password box.

  woodchip 23:04 23 Sep 2013

When Starting with XP CD in the drive choose setup, then let windows look for a operating system, it will find it, click on the one it finds then press R for repair. After it repairs it you will need to download all Windows Updates again

  Fruit Bat /\0/\ 12:30 24 Sep 2013

Normally if there is no admin password you just press enter

Download and burn a linux CD such as ubuntu this will allow you to copy the file across as per woodchip's suggestion or a the very least allow you to get all your data off be fore you reset it to factory settings or reinstall XP.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Sea of Thieves Review

Dell Canvas review: the cheap Wacom Cintiq alternative

How to use iMovie for Mac, tips and more

Comment filmer l’écran d’un iPhone ?