Windows XP Pro won't connect to Domain

  [DELETED] 00:15 17 Sep 2003

I can't get my newly installed Windows XP Pro to connect to my Windows 2000 Domain. I have other computers on the domain running both Windows 2000 and XP Pro, and one running NT 4.0 which is hardly ever used.

The PC's specs are:

Abit AT7-Max2 mobo
AMD AthlonXP 2600+ (333MHz Thoroughbred core)
512MB PC2700 DDR333
ATi Radeon 9600 Pro 128MB(Powercolor)
40GB Maxtor ATA 133 HDD (plugged in using Serial ATA adapter).

This motherboard has an onboard 10/100Mbps Ethernet adapter, and I have the drivers that were provided by Abit installed. It would appear that it is working, and when I view its status it has sent lots of data but received nothing.

When I try to connect to the domain it gives me a long error message. The important bit is this:

The error was: "No DNS servers configured for local system" (error code 0x0000267C DNS_ERROR_NO_DNS_SERVERS).

I have had trouble with DNS before, but the strange thing is that all the computers (except the NT 4.0 one that I have given up on) work OK.

I do get DNS errors in Event Viewer, along with others. There used to be loads, but I went through them all and was able to resolve most of them by following instructions I found on the net. The ones remaining are ones I can't get to go away but have never caused any obvious problems.

Sorry to make this post so long, but I've installed XP and need to get it on the network to connect to the internet in order to activate it.

  [DELETED] 13:05 17 Sep 2003


  [DELETED] 13:14 17 Sep 2003

Turn off the XP fiewall and try going Start then Programs then Accessories and Command Prompt type in ipconfig /flushdns now Go Control Panel System and try adding the computer to the network from there.

  [DELETED] 13:20 17 Sep 2003

The XP Firewall was already switched off when I checked. However, the server is running ZoneAlarm, but this has never caused a problem with the local area network before, although it could be to blame for some of the errors I get in Event Viewer.

I'll try what you suggested and see what happens...

  [DELETED] 14:04 17 Sep 2003

I tried it but still no success. I thought I might be able to at least see other computers on the network if I set an IP address manually, so I gave it I clicked Start > Run and typed \\server, and was prompted for the Admin password, which I provided, and then I could see the files on the server, but I didn't see it in My Network Places.

I thought that since I was now connected I could join the domain, but the first time I tried it I was told something to the effect of "you can't be connected to the server twice", because I'd provided the password obviously. I logged off & back on again and this time I was able to get further. I provided the Admin password, but it couldn't connect me to the domain, and I got this message:

"Your computer could not be connected to the domain because the following error has occurred:

There are no more endpoints available from the endpoint mapper"

I haven't got the faintest idea what this means!

Any ideas?

  [DELETED] 15:39 17 Sep 2003


  [DELETED] 15:44 17 Sep 2003

I am looking its a RPC eror and I suspect it may well be Zone Alarm

  [DELETED] 15:47 17 Sep 2003

click here;en-us;822050

  [DELETED] 16:04 17 Sep 2003

Should I close ZoneAlarm while I get it connected, then open it again when it's working?

I would obviously have to switch off the cable modem while the firewall was disabled.

Is it possible that it will work OK with the firewall once the computer is on the domain, since all the others were OK, or might I have problems?

  [DELETED] 18:29 17 Sep 2003

A lot of questions

To start with I found this

"There are no more endpoints available from the endpoint mapper." That error, which appears at the bottom of the right pane, means that DNS Manager couldn't contact the name server on the target machine.

Befor turning off zone alarm can you try adding a group of IP addresses to the Trusten Zone eg to

and see if that solves the problem.

  [DELETED] 18:40 17 Sep 2003

Sorry if this post seems quite long...

Just tried it again. The situation now is that the XP machine is getting its IP address automatically, or so it would seem, because I am using it now on the internet, but it still won't connect to the domain. The unusual thing is that I don't think it's getting its IP address properly, because when I looked it's actually - what are the chances of that being the case if it was automatic?

Here's what I did since the last post:

1. Switched off cable modem and closed ZoneAlarm on the server.

2. Cleared all logs in the Event Viewer.

3. Tried to connect to domain (right-click My Computer > Properties > Computer Name > Change...)

4. Provided Admin password when necessary.

The same error appeared as mentioned above (There are no more endpoints available from the endpoint mapper). This is still happening now.

When I went back to the server, there were, as I expected, errors/warnings in Event Viewer.

In Application Log: EventID 1000 (Windows cannot determine the user or computer name. [Return value 1753])

This appears every 5 minutes.

There are 2 Warnings in the System Log:

EventID 5773 and EventID 5781

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

How to watch the World Cup for free on TV and online

16 illustration tips for packaging

Best external graphics cards (eGPUs) for Mac

Les meilleurs antivirus pour Mac (2018)