windows xp pro updates

  robbg 17:09 13 Sep 2005
Locked

I have been through all your questions and answers to save you good people writing the same answer again. but I cant find anything. I know there is someone out there who will have the answer. So here goes.
PROBLEM : - I cant get any automatic or manual updates for my Windows xp pro. I have been through everything that the windows site suggests. But still no luck.
This is what I keep getting :- "Could not start Auto Updates service on local computer "error 1083". The executable program that this service is configured to run does not implement this service".

I have been into "services.msc" made sure the startup type is automatic. But when I click on verify the service has started. The above problem is what I get.

I have been into "HKEY_Local_Machine\Software\Microsoft\WindowsNT\CurrentVersion\Svchost" and opened up the "Netsvcs key". But there is no "Value Data" in there in order to add the "BITS and WUAUSERV" to the list of services.
This is all there is:-
NAME DATA TYPE

Default REG_SZ
AuthenticationCapa REG_DWORD 0x00003020 (12320)
ColnitializeSecurity REG_DWORD 0x00000001 (1).
So please where would I add the "BITS and WUAUSERV" ?
Sorry the above has all broke up and I cant get it to go straight.

Also the path where the problem executable file is located is:- "C:\Windows\system32\svchost.exe -K.netsvcs" the dash before the K is very very small. Could there be a problem with the " -K". as it doesn't look right to me?

Sorry about the mess just cant get it right.
Please see what you can do to help me
Regards
Robbg

  Stuartli 17:37 13 Sep 2005

See:

click here

and also try going to the Update site from the same link.

  Stuartli 17:38 13 Sep 2005

Today's Security Bulletin updates have been put back as there have been problems with a particular update.

See:

click here

  robbg 18:06 13 Sep 2005

No sorry Stuart. no updates would go in. It tried to put "windows installer 3.1" and KB892130 valudation tool in but neither of them would go in from both the sites in blue on the right.

  Stuartli 22:27 13 Sep 2005

Just a thought - you haven't Disabled Windows AutoUpdates in the Security Center?

  Stuartli 22:34 13 Sep 2005

By the way I've checked your Registry links above (Netsvcs and AuthenticationCapa) and the usual double click on the listed entries in the right hand section brings up the usual panel to make alterations if required.

  robbg 07:39 14 Sep 2005

Hello Stuart. It has and still is enabled. I just checked again.
There are three names down the right side of(netsvcs). All of them you can double click on and all say the same thing. So I have already put them both (BITS and WUAUSERV) on to the top one (Default) as there are none on that one. but it hasnt made the slightest difference. I also removed the (and) from it but still did'nt do anything.
When you looked at yours did it have the(-k)in it before the (netsvcs)

  robbg 16:10 14 Sep 2005

Hi Stuart
I bet you have lost you patience with me being so doppy. Well anyway. In order to download "Microsoft baseline". I had to let it install the valuation tool from microsoft. Once I had done that I ran the baseline tool and it told me I needed to install 28 updates that where missing. So when I went onto the result details it showed me all that was missing. I am now able to install them but only 1 at a time.
Thanks a million for all your help
Robbg

  GaT7 19:12 14 Sep 2005

To know if the Win updates installed correctly, after applying all, download+install+run the free Belarc Advisor click here.

Belarc will also list your PC's hardware & software info. There is a better tool called Everest click here, if you'd like to know more. G

  robbg 08:36 15 Sep 2005

thanks have just got them both to have a look

  uisquebeathus 15:31 15 Sep 2005

If you know how to use registry editor go to each hive heading :-
HKEY_CLASSES_ROOT
HKEY_CURRENT_USER
HKEY_Local_Machine
HKEY_USERS
HKEY_CURRENT_CONFIG
Right click and check that the permissions are all the same
Administrators
Everyone
ALSO note that there should be a Tick in the box for FULL CONTROL of each permission.
if that still doe not work :-
Go into internet explorer Tools internet options and delete all cookies,delete all files, good luck

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

AMD Radeon Adrenalin release date, new features, compatible graphics cards

Turn a photo into 16-bit pixel art

iMac Pro release date, UK price & specs

Comment suivre le parcours du père Noël ?