Windows won't recognize my printer

  ened 16:48 13 Mar 2013

I am desperate to print some documents. I have just set up a new machine and am using Windows 7 as I was in my old machine.

I had no problem with the old machine but this one only recognises the printer in Devices and Printers as 'Other'.

I can't even seem to find the right download for the drivers.

The printer is a Canon ip3000 and if any one can help you will be getting me pout of a pickle. I must print these documents by tomorrow.

  wiz-king 17:22 13 Mar 2013


  ened 17:30 13 Mar 2013


Your link takes me to a canon page with this message:

The page you were looking for could not be located on the server.

  ened 17:35 13 Mar 2013

I followed the Support link from that link but it doesn't give you the basic drivers.

I can't help thinking I am missing a trick here because I don't remember having this trouble a couple of years ago when I set up the same printer on my other Win 7 machine.

I am currently using the original Hard Drive for the documents etc on it. If I can't resolve this tonight I am going to have to re set up my opld machine just to get these documents printed. That will be a drag!

  chub_tor 18:16 13 Mar 2013

According to the Microsoft Compatibility Centre the ip3000 is fully compatible so Windows 7 should find the correct driver for it. I would have one more try of uninstalling the "other" printer and try again. Right Click on it and select Uninstall this Device. Either switch the printer off or unplug the USB connection and reboot. Once the PC is up and running switch the printer on (or plug the USB back in again) and let Windows find the printer. See if that works.

If you work your way through the Canon support website for the ip3000 for English and Windows 7 software I found the bottom one was "Canon Inkjet Printer Driver Add-On Module File version: 1.10" which adds functions for Win 7 and Vista

  lotvic 18:23 13 Mar 2013

I can't get the downloads page either - it times out (tried several times) page must have a problem at the moment.

  lotvic 18:27 13 Mar 2013

well if chub_tor managed it okay, it must be me....

  ened 02:26 14 Mar 2013

I've resolved this but I don't know how.

I have MS Office 2010 installed and it was registering One Stop 2010 as the default printer. As soon as I uninstalled it the ip3000 moved from 'unspecified devices' to the main section and automatically installed the drivers.

  spuds 09:19 14 Mar 2013

It might not be the answer, but I had a similar problem with an HP printer. Contacting HP support, they suggested that I used another driver from another printer in their range. It worked, problem resolved.

So perhaps contacting the printer manufacturer might resolve the issue?.

  ened 12:26 14 Mar 2013

spuds This was bugging me so I was up at 2:00 and looked at it with a fresh outlook.

MS Office has something called One Note. For some reason this had been designated the Default printer!!!

I had Office on my old machine but I reckon I must have installed the printer before I installed it.

Anyway, at least I don't need to re-instate my old machine now!

Thanks for your suggestion.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Samsung Galaxy A8 review: Hands-on

Illustrator Juan Esteban Rodriguez on creating highly detailed official film posters for Star Wars…

iMac Pro review

Quelle est la meilleure application de podcast pour Android (2018) ?