Windows update problem

  Housten 12:11 06 Nov 2012

Good afternoon, Gentlemen,

I am hoping someone can help me, with Microsoft updates. I hadn’t updated since 22nd September, because we were away on a 22 day cruise and since we got back there have been some problems. A week ago Saturday or Sunday I installed a programme on my computer with no problem but when I tried to do so this morning the box that came up had a red line down the right hand side. I clicked on ‘check for updates’ and the box with the blue square going from left to right appeared. For about 2 or 3 seconds, then the bigger box was back with ‘Windows could not search for updates’ and ‘An error occurred while checking for updates for your computer’ with ‘Code 800704022’. I then clicked on getting help, which brought up a page which listed the error, and clicking on that brought up another page with a ‘Fix it’ logo and programme. I clicked on it, and it went through and said ‘Problems found’. It then went through some stuff and listed as fixed two things – ‘Windows update components must be fixed’ and ‘Problem with Background Intelligent Transfer Service (BITS)’. Except they are not fixed, as I have re-run them a further twice and have got the same result. Does anyone have any idea what I have to do to correct this??

I do not know if it is – but I suspect so – something to do with the fact that I tried to install ‘Diskeeper’ from the DVD in December’s edition of the magazine also this morning. It seemed to be going through when a box appeared: ‘Windows Installer Service could not be accessed. This can occur if the Windows Installer is not correctly installed. Contact your support personnel for assistance’! As I am a pensioner at home who are my ‘support personnel’? Hopefully you gentlemen!!!!

One further point: I have been rebooting my computer on a fairly regular basis this morning. I noticed at the screen which gives the memory check that there seemed to be a difference in the memory – the second number – and the first – what I have assumed to be the available memory. So I saw there was a programme from ‘Crucial’ on the DVD and thought that that would test my memory. On clicking on it, I got taken to a PCA page with programmes for sale and no ‘Crucial’ no matter where I looked. Has anyone else had this problem?

Any help advice/comment/assistance/guidance or anything else will be very much appreciated by myself.

Many thanks in advance.

  Forum Editor 12:26 06 Nov 2012

Can you tell us which version of Windows is installed on your computer?

  Housten 12:39 06 Nov 2012

Forum Editor,

Sorry, being brain dead at times............

Anyway I have Windows 7 64Bit Home Premium as OS, the computer is almost 6 years old, has a twin core with 4 GB of ram. It was originally 1.5 or 2 GB but I upgraded it a couple of years ago.

Many apologies, but when panic starts................

  spiderlegz 14:17 07 Nov 2012

Hi Housten, I have experienced similar issues in the past & I suspect that your CMOS battery has died & needs replacing. I especially suspect that the battery has died because your system has been dormant (no power at all) while you have been on holiday. If the Cmos battery dies, all the settings on your motherboard are reset, including the time & date. If the time & date are incorrect (check your taskbar clock), then your windows update will not be able to function & give you the error. Change the Cmos battery on your motherboard (it's approx 20mm in diameter & should be 3v) for a new one, correct the time & date (especially the year), reboot your system & then run the windows update. If the CMOS battery is not the issue, then you could try a system restore, back to 2 or 3 weeks ago & then run a full virus & malware scan, just to be sure.

  Housten 14:58 07 Nov 2012


Good afternoon,

I think you have replied in the wrong post, and I have got the new battery installed and up and running!

Doesn't anyone have any ideas, please???

  spiderlegz 15:31 07 Nov 2012

Nope i've definitely got the right post. Did you check the date & time etc after installing the new battery? Is your windows 7 the full retail version & not just a trial or dodgy copy? because the update service will stop working after 160 days if it's a trial version you see.

  spiderlegz 15:42 07 Nov 2012

Something else to try:

Go here

Download & install the update

Run windows update again

Download & install all available updates & reboot your system.

  lotvic 15:43 07 Nov 2012

spiderlegz, new cmos battery was put in when Housten came back from holiday, see thread

  spiderlegz 15:48 07 Nov 2012

Ok thanks lotvic.

  Housten 17:09 09 Nov 2012

Good afternoon,


Thanks for your link to a microsft site, which I went to, and tried to download the file – KB2647753. The site then said “The update is not applicable to your computer”!!! Which, shall I say, flummoxed me a bit. So I thought I would check my previous updates, and then found that it had been installed on 18th August!!

By this time I was getting somewhat annoyed with my memory, as I couldn’t remember how to get to my starting programmes, which I knew were in the same place as a load of other programmes, which I thought might include something to do with installing Windows programmes. I did, finally, remember it – ‘msconfig.sys’ or ‘.exe’, I can not remember which!! Any way I got it running and there was a tab with ‘services’, so I clicked on it and there they were, all sorts of stuff with boxes to be ticked or unticked. I looked down the list and found ‘Windows Installer’ UNTICKED!! I thought that this could be my problem, so I ticked it, and looked through the list for others that were unticked, and I ticked another 3 or 4, just for safety. I clicked on ‘apply’, ‘OK’ and then re-booted the computer. The first thing I then did was check for updates – there were 20 I got altogether - I installed, which necessitated another re-boot!

But it would appear that I have corrected whatever happened. I am not saying I unticked these because - although it stated that the alterations were made on 29th October - I have no recollection of doing it! Anyway I will try loading a programme to see if I have completely done it, so I am hoping I won’t have to come crawling back asking for help – well at least on this any way!!!

Many thanks to everyone for their help and assistance.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

iMac Pro review

Illustrator Charles Williams on how to create magazines and book covers

iMac Pro review

Les meilleures prises CPL (2018)