windows update issues and msxml3.dll problem

  robert1960 15:01 15 Sep 2007


Can anyone help? I have spent the last 2 days trawling every help forum and am getting increasingly frustrated.

System details
2.00 gigahertz AMD Athlon XP running windows 2000 professional Service Pack 4

To avoid running the same solutions again I am posting what I have done to date in the hope that someone, somewhere, will come up with a possible solution that I haven't already tried. Advanced apologies for the length of this post.

By way of background info
Downloaded Belarc Advisor which is a nifty little program that simply details everything on your PC including Missing Microsoft Security Hotfixes.

I have automatic updates enabled but it has obviously missed these or failed to install them. So went Microsoft to manually update these security missing security Hotfixes And that is when my problems began!

I am unable to update manually as i remain in a constant loop. First MS tries to establish if I have the latest windows update software on my PC and then brings up an error screen

" Files required to use Microsoft Update are no longer registered or installed on your computer. To continue:
Register or reinstall the files for me now (Recommended) Continue"

Which I duly press and arrive back at
" Files required to use Microsoft Update are no longer registered or installed on your computer. To continue:
Register or reinstall the files for me now (Recommended) Continue"

I came across a wurepair.cmd utility on a tech forum that supposedly repairs this issue. Lots of responses that claimed success for this issue. It gave the following advice

It sounds like some of the services or the files (or both) which are required for the Windows Update service to run are no longer running or registered with the system.
Let's try stopping the services, re-registering the files used and restarting the services used for Windows Update and see if that makes a difference.

Create a new text file using Notepad or your favorite text editor and copy and paste the following lines into it:
%windir%\system32\net.exe stop bits
%windir%\system32\net.exe stop wuauserv
%windir%\system32\regsvr32.exe %windir%\system32\atl.dll
%windir%\system32\regsvr32.exe %windir%\system32\jscript.dll
%windir%\system32\regsvr32.exe %windir%\system32\msxml3.dll
%windir%\system32\regsvr32.exe %windir%\system32\softpub.dll
%windir%\system32\regsvr32.exe %windir%\system32\wuapi.dll
%windir%\system32\regsvr32.exe %windir%\system32\wuaueng.dll
%windir%\system32\regsvr32.exe %windir%\system32\wuaueng1.dll
%windir%\system32\regsvr32.exe %windir%\system32\wucltui.dll
%windir%\system32\regsvr32.exe %windir%\system32\wups.dll
%windir%\system32\regsvr32.exe %windir%\system32\wuweb.dll
%windir%\system32\net.exe start bits
%windir%\system32\net.exe start wuauserv
Save the file with a name of "WUREPAIR.CMD" someplace you will remember such as your Desktop or a directory like C:\TEMP including the quotation marks in the filename so the text editor doesn't accidentally save it with a .TXT file extension.
Run the WUREPAIR.CMD file from the Command Prompt (filename: CMD.EXE ) or by double-clicking on it.

I did this and all registered successfully except one....I got the following error message
DllRegisterserver in C:\WINNT\system32\msxml3.dll failed. Return code was : 0x80070005

I have tried to register msxml3.dll in the cmd but it always comes back with the same 0x failure code.

I installed Microsoft XML Parser (MSXML) 3.0 Service Pack 7 (SP7) but still no joy.

I installed the MSI file, still no joy.

I have tried through cmd to register and deregister msxml3 but get failures on both account

I can see that msxml3 dll is in the wn32 folder but obviousy there must be some corruption.

I ran wise registry cleaner (freeware) in the hope it would repair this dll file but to no avail except now I get a blank page on ms update

Can anyone help as I am at my wits end? I am sure I have altered some permission settings and am now on the verge of messing up my registry completely in my efforts to resolve this.

  birdface 15:12 15 Sep 2007

Have you tried this one,click here or this here

  robert1960 15:30 15 Sep 2007

Thanks for the prompt response buteman but unfortunately it comes unstuck when it hits the dreaded msxml3.dll

  birdface 21:13 15 Sep 2007
  birdface 21:22 15 Sep 2007 here it will give you something to look at,But no doubt you have already tried.

  robert1960 21:45 15 Sep 2007

Thanks Buteman, Been there done it.

Have sorted it (I hope). Ran Dial a fix, AVG (Issues & Registry Integrity), rescanned with Wise Registry Cleaner and tinkered with permissions. Rebooted and Hey Presto Manual Express and customs page loads.

No msxml3.dll issues but I am having issues with these 2 updates that fail to install however much I try. The error codes contradict each other.

Microsoft .NET Framework 1.1 Service Pack 1
Security Update for Windows 2000 (KB938827)

Windows Malicious Software Removal Tool - September 2007 (KB890830)

I believe that I must have compromised ny permission status in previous tinkering, hence (maybe)the difficulty I was having in unregistering Msxml3?
Still think I need to tweak a little more as manual updating is taking an age and

  robert1960 22:00 15 Sep 2007

I'm getting error code 0x80246008
The necessary services are disabled or unavailable.

This error may occur if one or more of the following services are disabled or unavailable. Background Intelligent Transfer Service (BITS) Event Log

It suggests the following, but doesn't resolve it.


1. Set Background Intelligent Transfer Service to Automatic and verify the Status is Started.

Click Start.

Choose Run.

In the Run box, type services.msc.

Click OK.

Find the Background Intelligent Transfer Service service, and right-click to select it.

Select Properties.

In the Startup Type list, select Automatic.
Verify the service Status is Started.
Click OK.

  birdface 22:37 15 Sep 2007

click here looks like it may be something to do with the up-dates.

  robert1960 22:47 15 Sep 2007

I've done this and Iam going round and round in circles
error 1086 do following
Microsoft Windows 20001.
Click Start, click Run, type services.msc, and then click OK.
2. If one or more of the following services are not running, right-click the service, and then click Start:• Com+ Event System
• System Event Notification(GENERATES ERROR 1083)
• Windows Management Instrumentation Driver Extensions

configure the bits and comms and events systems,windows management instrumentation Driver extensions. (GENERATES ERROR 1086) ROUND AND ROUND ROUND I GO LOL

  birdface 23:13 15 Sep 2007

You could try downloading this one manually. click here then we can see if we can find the other one.

  birdface 23:24 15 Sep 2007

Or maybe better downloading that last one from here

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Dell XPS 13 9370 (2018) review

HomePod review

Comment regarder les Oscars 2018 ?