Windows Task Manager queries

  CurlyWhirly 16:15 01 Nov 2004

Hi. I always thought that ONLY essential operating systems processes like csrss.exe are blocked when you try to end the process?
For example if you try to end the process for csrss.exe you have a message "Unable to terminate Process. This is a critical system process. Task Manager cannot end this process".

I have the registered version of a2 and when I attempt to end the process on a2guard.exe I am confronted with this message "Unable to terminate Process. Access is denied".
Is this protection built in to stop rogue Malware from ending this process should it 'gain a foothold'?
What I mean is that I have read on the net that some viruses or worms attempt to disable anti-virus software, firewalls, etc.

Another question related to Windows Task Manager and this is sometimes when a program is 'not responding' you click on it (in WTM) and select End Process and it doesn't work as as soon as the process or application is shut down another one starts up which is really annoying and this continues in a never ending loop.
When this happens I find the only way to get out of the loop is to reboot.
Does anyone know WHY this happens and if there IS a way to get round it?

  keith-236785 16:54 01 Nov 2004

if you click on end process and it appears not to work, give it a little more time, sometimes it takes a while for the process to stop before the end task box opens and it will close.

other times it will just simply have crashed the system and you have no choice but to reboot.

  bertiecharlie 17:53 01 Nov 2004

Most security programmes will have some form of inbuilt protection against termination but its far from foolproof. If you want 100% protection against termination then you need to look at ProcessGuard click here The new version of this product has just been released. I'm trying to weigh up whether all these extra security applications are overkill, however, lol. (A good imaging programme is probably the best security app you can have).

About your second question, does this relate to one specific process you are having trouble ending?

  CurlyWhirly 20:18 01 Nov 2004

About your second question, does this relate to one specific process you are having trouble ending?

Hi. Yes as I said before I have the registered version of a2 and according to advice that I have read I need to try to deactivate the guard with WTM so that the a² updater can update due to a 'bug'!

"Hey, that worked! I shut down a2guard.exe with Windows Task Manager, ran the Updater with a² StartCenter, then restarted a2guard.exe from inside the C:\Program Files\a2 folder.

Seems kind of roundabout, but it worked. Thanks, Christian! now if i can only remember the sequence..."

The above is a reply from someone who managed to shut down the a2guard.exe using WTM in order to run the a² updater as there is a 'bug' in the updater and the only way to resolve it is to disable the a2guard IN ORDER TO UPDATE.
A catch 22 situation!
I have posted in the a2 forum yesterday but as yet I have had no reply.

  bertiecharlie 20:29 01 Nov 2004

I don't have the paid for version of A2 but if you go to Start\All Programs\Administrative Tools\Services does it show anything for the A2 guard. If it does, you could try stopping it from there and setting it to disabled while you try to update. Just a thought.

  CurlyWhirly 20:44 01 Nov 2004

Thanks. I have looked in the Services section for the a2 guard but I can't find anything!
By the way when I close the guard on the Windows Taskbar it is still showing in WTM so I am just going to have to wait for them to sort the problem out even if it means uninstalling and reinstalling a2 again!

  bertiecharlie 20:52 01 Nov 2004

Good luck. I'm sure you'll get a reply on their forum.

  CurlyWhirly 20:59 01 Nov 2004

Good luck. I'm sure you'll get a reply on their forum.

That's what I like about this PCA Forum there are many thousands of registered members and yet when I go to other forums (a2 included) there is an online figure and normally there is only a few dozen or a few hundred online at any one time hence the delay in my query being answered!
I will mark this as resolved and send one of the a2 Administrators an e-mail as I may be more likely to get a reply this way!

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

HP Envy x2 review: Hands-on

How Sketch and InVision have revolutionised our design workflow

The best tech gifts for Christmas 2017

Les meilleurs jeux de société (2017)