Windows No Disk Error - Revisited

  steve1968 20:26 22 Jul 2005

Please help this is driving me nuts!!! My computer (Gigabyte sli MoBo AMD FX55 2 x 6600gt's WD Raptor SATA HDD 1GB Ram etc) is currently running XP (SP2) When I start-up it shows an error message in a window ("Windows no disk There is no disk in the drive")causing me to click cancel two times or so to continue. Cameraman has posted a similar message in 04/05 in this forum but the problem did not appear to be resolved. I have installed a Multi card reader/USB unit that I suspect is the root cause of these error messages. If this device is unplugged from the MoBo all is ok, but this is not exactly a satisfactory solution! Any help would be appreciated on this one.

  woodchip 20:30 22 Jul 2005

why are you reading card all the time? I just plug mine in when i Need it

  steve1968 21:02 22 Jul 2005

I should have said the drive concerned is an internal drive so not really convenient to be plugging/unplugging it into the Motherboard all of the time.

  Dipso 22:11 22 Jul 2005

I was getting No Disk errors but they were related to Zone Alarm, QuickTime and my card reader. In my case I had to uninstall/reinstall my card reader (and still do everytime I update ZA!)and remove Quick Time (I now use QT Alternative instead), however, my errors were headed ZL Clent.exe there is no disk and QTtask.exe there is no disk, so differ to yours.

Do you still get an error if you bootup with a card in the card reader, not ideal but I read somewhere that it can stop the error from occurring.

There is something in the MS knowledge base, I am trying to find it, but it didn't help me.

  Dipso 22:15 22 Jul 2005
  steve1968 22:54 22 Jul 2005

Dipso thanks for your assistance although the problem remains as before! I dont use Zonealarm, and have only very recently installed Quicktime, and the problem with the No Disk error predates this installation.
I have tried to boot with a memorystick in the cardreader but this not not resolve the issue.
I have looked at the MS Knowledge base thread previously and it does not appear to be the same problem to my (limited!)understanding.
I have googled the problem and other people have similar issues but no definitive solution has been found by me to date.
Told you it was driving me nuts!!!

  Dipso 23:09 22 Jul 2005

Not a permanent solution but as it isn't convenient to unplug it, can you not disable (not uninstall) the card reader in device manager, as you aren't likely to be needing it all the time, then just enable when required.

As you say you have "Googled", did you read the post where the poster said the problem eventually "went away", here's hoping ;)

  steve1968 23:58 22 Jul 2005

I did what you suggested and disabled the card reader drives in device manager and it worked, no more pestering error messages. Would like to know of a permanent solution that did not involve disabling the drives in this way though.

Yes i did see the post you referred to about the problem apparently resolving itself, not sure how that happened though...

  yogibear 00:11 03 Jul 2006

I've had this for the last couple of days, not installed new hardware since a new HDD 2 weeks ago, so I don't think it'sthat. It happens when I try to load Adaware,it lets me go as far as loading definitions and then it just pops up faster than I can cancel it.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

iMac Pro review

Illustrator Charles Williams on how to create magazines and book covers

iMac Pro review

Les meilleures prises CPL (2018)