Windows Media Player in Vista - Repair/reinstall.

  ianeon 08:48 09 Dec 2008

Good morning,
I run Vista Home Premium with Windows Media Player( 11.0.6001.7000 ).
For some reason-unknown to me- WMP has gone from my computer, it is not in my programmes file and using "search" I cannot find it.
I have GOOGLED the problem and discovered that it can't be repaired or removed !
I would be grateful for any help/information in getting it back.
I have in the meantime installed MEDIA PLAYER CLASSIC which is a fair replacement.
Thank you for your time.

  sinbads 09:20 09 Dec 2008

WMP11 in vista can be a pain as you say you cannot repair or remove,Are you sure WMP is not in your program files strange that WMP is missing? I'm not sure there is a way to solve your problem apart from a vista repair.

I did have a problem with WMP11 ;but SP1 cured it, if its a recent occurance you could try a restore to when it worked

  ianeon 15:53 09 Dec 2008

Sinbads - Thank you for your interest - I checked in my "C" drive and it has gone !
I tried system restore but that didn't help.
The only thing that I have done to my comp was to try the Firefox browser.
I am reluctant to try a Vista repair just in case I make matters worse( cos I wouldn't know what I was doing ) - lol

  sinbads 18:06 09 Dec 2008

WMP is part of the OS on vista, to be honest i've not heard of anyone with a missing WMP, loads of people with it not working missing codec.

suppose you could try downloading it click here

You could try start type run in the box then select the run above, type in the box sfc /scannow then ok(note the space after sfc);but doubt this will work.

  ianeon 18:32 09 Dec 2008

Sinbads - Thank you - but the link you have given me is for an older version than the one installed.
Do you think that it is possible to find WMP on my Vista disc and then copy and install that ?

  sinbads 18:44 09 Dec 2008

you could only do that with a repair should you decide to do that
click here
latest WMP11click here

  peter99co 18:47 09 Dec 2008

The SP1 update contains the latest version of WMP.

  ianeon 20:55 09 Dec 2008

Sinbads - again thank you - but the link you gave goes to the "64" version, not the "86".
If Peter99co is correct perhaps I could uninstall SP1 and re-install it - lol

  ianeon 21:53 09 Dec 2008

I have just run "Belarc Advisor" and it confirms that WMP is not on my computer

  sinbads 22:30 09 Dec 2008

Worth a try it did fix my problem as isaid in my earlier post make sure you create a restore point first

  MCE2K5 02:15 10 Dec 2008

Can you run Windows Media Center, This click here is what I mean.

If you can run it, See if you can play a Music CD, Film DVD or any Video file or MP3 with it.

If it does play, Then wmplayer.exe is still on your machine.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Samsung Galaxy S9 review

Explore Milton Glaser's iconic poster designs from the 1960s to present, including Bob Dylan, I…

What to expect at Apple's 27 March education event

Idées cadeaux pour geeks et tech addicts