Windows Defender

  Melchior912 13:03 23 Feb 2006

Error Msg: 0x80040154 Class not registered. This occurs when I try to update the definitions. Informed that they are 27 days out of date.

  Fingees 14:54 23 Feb 2006

Uninstal it, and download again.

It worked wit me.

  Dellman 15:26 23 Feb 2006

I only installed it yesterday.....!!??

  Dellman 15:26 23 Feb 2006 in same problem

  tristar 18:37 23 Feb 2006

On another page I saw the same problem, they advised putting the line below in 'Start - run'
and open it.
I've done so and it cured my update problem.

Msiexec /x {A5CC2A09-E9D3-49EC-923D-03874BBD4C2C}



  tristar 18:42 23 Feb 2006

As I understand it, if all is well with defender it does not appear in your start tray. It only appears if some response is required from you.

  chub_tor 19:03 23 Feb 2006

Your fix worked for me. I was bugged by the 27 days out of date issue and the constant request to update and this fixed both problems. I was a bit apprehensive with the request of "do you wish to remove this product?" so I made a restore point and ploughed on. Now I'm glad that I did. Thanks.

  J B 19:39 23 Feb 2006

The fix also worked for me. Now everything is ok. J.B.

  Dellman 17:53 04 Mar 2006

I'm having problems with do I uninstall Defender? Can't see an uninstall option.

  Dellman 10:02 06 Mar 2006


  Dellman 11:07 06 Mar 2006


This thread is now locked and can not be replied to.

Elsewhere on IDG sites

HTC U12 Plus review: Hands-on

Best Android emulators for Mac

TV & Streaming : comment regarder Roland Garros ?