Windows 98se & USB - Again!

  Wharfhouse 09:22 22 Oct 2007

Hi to all out there!

I've just joined in the vain hope of sorting out an irritation with Windows98se and USB. I say vain hope because after scouring this forum and a zillion others I've "Googled", it sounds like this problem is far from new... 'though seems to be more of an issue with XP.

It's the age old problem of flash drives and external hard drives not being picked up by the OS when plugged in. Now where this problem differs slightly from seemingly all the others, is that when plugged in on boot up, then there's no problem; just won't do a hot plug-n-play.

What is even more irritating, is that it used to work properly, so it cannot be a hardware incompatibility problem i.e. bios, motherboard, hardware etc.

It's become a problem since performing a minor upgrade to a bigger hard disk, transferring the C:> drive over onto the new disk... apart from this the (desktop) computer works perfectly alright.

Checking Device Manager says everything is spot on with no conflicts, all devices recognized, no conflicting IRQ's, and everything set to how it should be according to USBMAN> website. I also tried altering drive letters under properties to see if this would make a difference... but still didn't show up in My Computer.

I checked "LastDrive=" in Config.sys which is set to 'Z', so no problem there then (even uninstalled TweakUI just in case there was conflict there). So, is there some system file that all this depends on that may have become corrupted or a registry key? I am now at a loss or, by all accounts, this is something I'm now going to have to live with.

Anybody with any inspirational ideas I can try? Thanks for any help.


  octal 09:28 22 Oct 2007

Whenever I have used USB flash drives on 98SE I have always had to install the driver for it. If you've reinstalled on a new HD could you have lost the driver?

  Diemmess 09:53 22 Oct 2007

You seem to have tried most things, but there's no mention of frequent advice offered on this forum to delete the USB controllers(all of them) in device manager and reboot.

I confess that 98SE is a fading memory, but that action does the trick with 2K and XP.

A caution. Do have the 98SE (and USB 2 if you have a separate card) installation CDs before you do it, in case the change requires them.

  Stuartli 10:42 22 Oct 2007

If you haven't already done so, try installing the Unofficial Windows 98SE Service Pack (a labour of love by the author):

click here

It will fully update your 98SE installation.

  ambra4 12:01 22 Oct 2007

Have you installed the driver for the flash drive??

Computers running Windows 98SE must have drivers installed.

Go to the Flash drive manufacturer's website and download the Windows 98 driver from the site

Computers running Windows 2000 and XP operating systems will automatically recognize the flash drive when plugged into the computer

  Fruit Bat /\0/\ 15:01 22 Oct 2007

It is important with All USB devices that you alays plug them into the same port everytime, or you end up overwriting the drive for the last device that was plugged into the port.
This is especially commom when using ports that are connected to headers on the motherboard i.e. front case ports.

Annoying I know but theoretically you need a port for every different device.
To get it all started again do as suggested by Diemmess and totaly uninstall and reinstall ALL USB devices in device manager.

  Wharfhouse 09:15 09 Nov 2007


After trying several other things, I tried the Service Pack download and have to say things are getting bad to worse. On opening the executable I get "A required resource cannot be located". On opening other utilities I'm getting other error messages to the effect of "device attached to system not working". Clearly there's hidden a much greater problem, perhaps catastrophic when I say that files (fortunately backups) on a second internal fixed HDD suddenly deleted themselves whilst I was using a word processor! I wondered why I suddenly heard hard drive activity!

To me these may be symptoms of a virus 'though I can't see how as all files are checked after download with the latest software, so I'm beginning to think it would be quicker in the long run to wipe the slate clean and reformat the C drive and reinstall W98se. Fortunately I keep all my applications and data on other drives. What do you think?


  Diemmess 09:34 09 Nov 2007

W98SE good as it was, does tend to become 'dirty' with use.

The moment comes when you have to weigh up the very prolonged business of a complete reinstallation with a stack of CDs (drivers, apps, data, the lot), against more fuss and bother of the type you are having now.

The 'scanreg /restore' routine works magic with a sudden OS misbehaviour, but won't do any good with a problem that has been building up over time.
There may be an answer for the present state out there, but your troubles seem to be multiplying, and as a one time regular re-installer of 98, thats the way I would go now.

P.S. If you buy and use Acronis regularly, this should be the last reinstallation of Windows you need ever do!

  woodchip 10:03 09 Nov 2007

I use 98se most, although I have to XP computers. Your best way forward is a clean sweep. Only thing is, do not load a Virus back on with backups

  woodchip 10:06 09 Nov 2007

I use a PCI card that as
5 USB.2

3 Firewire and
Sata and
Pata Support

but don't think you can now get this board. it was a clearance from Maplins

  Wharfhouse 11:20 16 Nov 2007

Hi to all!

Just to update on developments, after trying many things including Marg7's tip, I have now successfully installed the Service Pack after finding the original download was a corrupt one, and learned all about MD5 & md5 checkers etc! and have to say it hasn't shown any of the negative side effects I had envisaged. However, nor has it resolved the original problem... but I have had a eureka moment!

I reinstalled the drivers for the Busbi flash drive and looked at it's 'settings' under Device Manager Disc Drives. I am given an option to choose a drive letter which I did, checked the "removable drive" box, but the "currently assigned drive letter" box remains greyed out after reboot, clearly the reason why it's not recognized in My Computer! More importantly, there's a checked box "Int 13 unit". The pop-up help for that says "if box is checked then device must be plugged in on startup". Well, that's exactly what's happening. So why is this now the case when originally it wasn't, and what's changed it? If I can sort that one out, I think this must be the cause of these problems!

Cheers, Sandy

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Huawei MateBook X Pro review

8 digital brands that designed custom typefaces to save millions

How to speed up a slow Mac

Comment résoudre des problèmes d’impressions ?