Windows 7 wont let camera to connect to ZoomBrowser

  MuDelta 16:59 01 Dec 2012

My Canon EOS 350 won’t to connect to this. Initially, the camera would not connect to anything but thanks to a Windows forum, I found that by changing the Communication setting on the camera from PC connection (which worked perfectly on XP) to Print/PTP I was able to download all my pics. to Windows Live Photo Gallery. (PTP stands for print to printer - is that intuitive or what?) So, at least I can live again! But, what’s up with ZP? After consulting the Canon website, I downloaded and installed the version of ZB for W7 but the computer still would not recognise the existence of the camera! I have tried all 4 of my free USB ports with no success (as suggested elsewhere on the Windows forum). I like and have got used to ZB and want to continue to use it.

Any advice?


  Woolwell 18:49 01 Dec 2012

Why bother with connecting by usb? Take out the memory card and put it in a card reader.

  MuDelta 18:53 01 Dec 2012

dr yes 64 bit W7

  hssutton 19:48 01 Dec 2012

what do you use Zoombrowser for? Also have you checked whether the EOS Utility sees your camera?

  hssutton 19:49 01 Dec 2012

Should have mentioned my 7D connects to both Zoombrowser and EOS Utility using Windows 7 64 bit

  hssutton 20:16 01 Dec 2012

Are you using the latest version of Zoombrowser. Version EX 6.7.2 is latest for the 350D, but have just check my version which is v

  MuDelta 11:55 03 Dec 2012


Yes, I was using the latest version for 350 but I have just run with still no result!

  MuDelta 12:54 04 Dec 2012

Unless something else turns up I am abandoning hope on this. Windows Live Photo Gallery will have to do though it downloads the entire content of the memory card every time and is therefore rather tedious!


  hssutton 14:05 04 Dec 2012

Not quite the answer you require, but have you tried The EOS Utility? Open the EOS utility switch on camera, select download. You can configure EOS Utility to transfer images direct to Zoombrowser.

As an alternative place the flash card in to a cardreader, open Zoombrowser and download direct.

  MuDelta 14:32 04 Dec 2012

The ink was hardly dry on my last post when I discovered here that downloads from 350D to PC using the EOS Utility are not supported by W7 and only downloads to "standard function of OS" work for the 32 bit version so I'm lucky that the "print/PTP" setting on the camera works for Photo Gallery. Moral:- Have an up to date camera. Built in obsolescence!

Thanks all for your contributions. Question answered if not problem solved!

  hssutton 17:23 04 Dec 2012

My apologies. I should have realized what the problem was, but not using Canon software I'd forgotten. Yes it annoyed me and many others also.

As you have already found out only the later cameras will work on Canons 64 bit software. However using a card reader will overcome your problem.

As for your comment "Have an up to date camera." Actually in the DSLR world you have an antique :) Even my old 30D a later model and twice the cost of the 350D will not work with Canons 64 bit software. Not that I'm really bothered as I only used the EOS Utility for tethered shooting. As I said earlier put your compactflash into a card reader and your Canon software will work Ok.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Samsung Galaxy A8 review: Hands-on

Illustrator Juan Esteban Rodriguez on creating highly detailed official film posters for Star Wars…

iMac Pro review

Quelle est la meilleure application de podcast pour Android (2018) ?