Windows 7 won't boot up..startup repair also doesn't function

  hg53 13:54 19 Dec 2014

Hey, my friend has a toshiba satellite L755D with windows 7. It suddenly stopped booting to windows, and automatically goes into startup repair, in which it says it cannot fix the error. After pressing every Function key on bootup, I cannot find the shortcut into the BIOS [to allow CD to be primary boot drive], instead only access to the standard boot menu for safe mode etc. None of these options yield anything, other than taking me back to startup repair...

So first I made a W7 rescue/boot disk as well as Ultimate Boot CD but both are unresponsive. After startup repair fails, it gives me in advanced options a command prompt, which by default is X: I can open D:\ and view the directory which has windows AND all my friend's documents [unfortunately]. It will read music CD's in command prompt but NOT any of my boot disks.

Any ideas would be great, particular getting into BIOS. Oh and I tried the bootrec /fixboot command to no avail in D:\

  Jollyjohn 15:31 19 Dec 2014

Go here click here Toshiba discontinued model support pages, look for the manual as there is built in recovery on this model. The manual should give correct key to start procedure and key for BIOS - have your tried Delete key??

  Fruit Bat /\0/\ 15:41 19 Dec 2014

Back up all your stuff before going for recovery option

or try first

In command prompt

x:\sources>bootrec /fimbr

x:\sources>bootrec /fixboot

x:\sources>bootrec /scanos

x:\sources>bootrec /rebuildbcd

  hg53 17:50 19 Dec 2014

Thank you both so much for your responses.. I tried all the command prompt suggestions and whilst it said that each executed successfully, it also said that found windows installations: 0 which doesn't sound great.

Yes I've tried pressing DELETE at startup but to no avail, will look more into the manuals now

  Jollyjohn 11:27 20 Dec 2014

Open back of laptop and remove and refit hard drive. I suspect the hard drive is not being detected.

  Fruit Bat /\0/\ 13:26 20 Dec 2014

I would have thought hard drive is detected if running win PE (Advanced tools from from the X partition.

There seems to be bad corruption of the C: partition hence the apparent loss of the windows installation.

try running chkdsk /f or chkdsk /r at the command prompt.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

HTC U12 Plus review: Hands-on

Best Android emulators for Mac

TV & Streaming : comment regarder Roland Garros ?