Windows 7 broadband connection error

  MikeStrafford 17:45 04 Jul 2014


Ok, here goes: I have just purchased an ACER ASPIRE with windows 7 preinstalled. I have tried to connect to the internet, with a known working cable and am experiencing the following: Action: click IE icon - result: opens a prompt from IE security saying - a website wants to open content using this program on your computer (BackGroundHost) - there is no such program installed on my PC. Action: click don't allow - result: opens some other stuff briefly before diverting to click here page entitled Navigation Canceled appears with the content: Navigation to the webpage was canceled what you can try: Diagnose Connection Problems

Click this and detecting problems appears briefly before aborting with the message: An unexpected error has occured. The troubleshooting wizard can't continue

Any ideas?




  Secret-Squirrel 19:11 04 Jul 2014

The first thing you need to try Mike is to change IE's homepage:

With IE closed, go to Control Panel -> Internet Options. In the "Homepage" section, delete everything's that there then type in the address of the one you want to use - Google or BBC are popular choices. Click OK when done then reopen IE and see if there's been any improvement.

  Fruit Bat /\0/\ 19:24 04 Jul 2014

Adwcleaner should remove things like BackGroundHost itis a standalone prohram so you can download to a usb stick and run on any PC from there.

  MikeStrafford 20:51 04 Jul 2014

thanks guys - trying the malware stuff - do you think that will cure the internet connection problem??


  MikeStrafford 20:53 04 Jul 2014

ahh! adwcleaner didnt work as it needed to update and connect to the internet, which this computer cannot do... i'll try the malwarebytes thanks - any OTHER suggestions - argch.. lol
THanks guys, really appreciate it, oand yes it is second hand...


  Secret-Squirrel 21:02 04 Jul 2014

"..... it is second hand..."

Ah, I was assuming it was a new Acer computer. In that case go back to Internet Options, click the "Advanced" tab then click the "Reset" button at the bottom. That should disable the pests that are preventing IE from working properly.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

OnePlus 6 review

Best art and design exhibitions in 2018

MacBook Pro keyboard issues and other problems

E3 2018 : dates, conférences de presse, billets et plus