win 98SE Error messages SYSTEM INI file,vxd file

  sherieann 14:56 09 Jul 2003

As you can see from my heading, I have problems.
while going through the startup process,it pauses, to continue I have to press any key. I have 4 error messages, 1st-VNETSUP.VXD , 2nd-Vredir.vxd, 3rd - Vredir.vxd and 4th is unable to load msn32.dll. When I have finished all that the system runs ok. What did I delete?
I have been on microsoft and found information on restoring a registry key under these 4 error headings. I must admit the answers were too complicated for me, I need a simpler step by step answer, I hope there is someone who can help.

  spikeychris 17:35 09 Jul 2003

A simpler step would be to use SFC.

Click Start, point to Programs, point to Accessories, point to System Tools, and then click System Information.

On the Tools menu, click System File Checker.
Click "Extract one file from installation disk," type the name of the file you want to extract in the "Specify the system file you would like to restore" box, and then click Start. This means type the files that are missing exactly into the box

In the Restore From box, type the path to the Win98 folder on the Windows 98 CD-ROM. Type the destination folder in the Save File In box if necessary, and then click OK.
Click OK, click OK, and then click Yes when you are prompted to restart your computer.


  sherieann 23:53 09 Jul 2003

Hi Chris the reply you have given is one of the things I have been trying, so I tried it again and again. At the end of the above I get error messages again telling me files do not exist, but they must be on the win 98se disk. Any other ideas? Can I re-install them from my comp? or download them, or could someone explain what I have done to the system to get these errors.
Most problems I have had before have been easier to sort out this one I just don`t understand what the files are or what they are for. thanks sherieann

  woodchip 00:00 10 Jul 2003

They belong to other software that you may have removed, but left you with probs and references that no longer exist

  kimjhon 00:54 10 Jul 2003

The files - at least the first 2 ( 3) are in my windows /system. Win98SE

I have experienced the prob of windows not finding a file in the Win98 CD.

You may have to hunt through the .cab files to find which one they are in. Then you can point windows to the exact path.

  kimjhon 01:09 10 Jul 2003

Hi again

Below is a response to a thread, from a member of this forum, that I saved.

Try to find the files in the installation CD.

Contrary to what is often believed, Windows Find tool can locate a file inside a CAB on the CD for you, so you don't need CabView for that.
To find items in .CAB files, open the Find/Search tool, type: *.CAB in the top field, and the exact name of the item your looking for (eg: mapi.dll) in the Containing Text field. Then if your looking on your Windows CD set the ROM drive in the Look In field. It will then find the file you want, showing the .CAB file it's in.


  woodchip 10:53 10 Jul 2003

Yes that's all very well and good but you will not find files that do not exist on the installation CD, Windows SFC look's for deleted files and corrupt files it does not know where they are located i.e. CD's.... System folder stores all dll's including Programs the files you want are on Programs that do not work correctly or have been removed, you will only find these on the relevant CD

  ollie < one> 00:39 11 Jul 2003


  sherieann 01:11 11 Jul 2003

I am still trying to work this one out with the help from you all. I did use the SFC as soon as the problem started but it did not tell me that the system had any deleted or corrupt files.
I am still not sure are the 1st 3 vxd files a software program ? that was deleted by me.
and what relevence do they have to the error unable to load msn32.dll. As I said befoe everything is running ok, it is just so annoying.
Maybe I should just leave it running all the time, or dare I say get someone to look at it for me. ( I did upgrade to AOL 8, and when I re- started the problem was there, just wondering if that has anything to do with it?).
I still need pointing in the right direction. I don`t want to give up just yet. thanks sherieann

  BurrWalnut 08:24 11 Jul 2003

I've had this in the past and from my fading memory I think I removed them from the registry.

Take a backup of the registry first (most important) them delete one of them and reboot. If all appears OK, go on to the next one.

You can always restore the backup registry if things go pear-shaped.

Good luck

  Jester2K II 08:40 11 Jul 2003

"I did upgrade to AOL 8, and when I re- started the problem was there"

Ahh AOL....

OK from what i can find these files are to do with the Networking Procols. click here

However it might be that installing AOL has made changes to your Networking protocols and hasn't cleaned up properly (surely nit???)

Anyway, IF everything is running ok then the best route is to remove all entries for these files from the registy. Back up the registry first then........

Click Start>Run...

In the Open box, type REGEDIT.

Click the Edit menu and choose Find.

In the Find box type VNETSUP.VXD and press Enter.

Delete any occurances of VNETSUP.VXD on the left hand side. When you get to the end close regedit.

Click Start>Shutdown. Choose Restart, then click Yes.

Check the message for VNETSUP.VXD has gone. Then repeat for the VREDIR.VXD.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

iMac Pro review

Illustrator of witty, relatable Instagram comics Julia Bernhard touches on our humble moments

iMac Pro review

Quelle est la meilleure application de podcast pour Android (2018) ?