Win 2000 Pro and XP home network setup problem

  dragondelboy 15:07 12 Nov 2005

Hi, am having troubles setting up a network (through a hub and crossover cable). One Pc is running XP home and the notebook is running win 2000 professional (recently recovered using disc). The XP pc is the main one is directly connected to internet. Have set up a workgroup easily but when inserting my XP CD into the notebook and try running 'perform additional tasks' then set up network. I get a message saying that I should refer to the help file on the appropriate system,98, 98SE, 2000 etc. I have tried looking in there but have not found anything useful.
Can anyone help?


  LastChip 21:13 12 Nov 2005

You don't use the two together.

Either use a crossover cable directly connecting the computers, or, use a hub with patch (straight through) cables.

Or do you mean, you have tried each system independently?

  dragondelboy 21:37 12 Nov 2005

Hi, have tried both independently. Does it matter that one windows is Pro the other home?

any ideas?

  LastChip 22:04 12 Nov 2005

First, make sure all firewalls are turned off until you succeed in making the network work properly.

Second, make sure on the W2K machine, you have an identical user account to the XP machine, and log in using that account while trying to get the network working. It should have full administrator privileges.

Three, make sure the network name is the same on both machines. Contrary to popular belief, this is not absolutely necessary, but it does make the whole troubleshooting process easier.

  dragondelboy 10:47 13 Nov 2005

Hi, that seems to have helped. Both recognise each other now. I have got access to the notepad (Me2000)via the Xp pc but not the other way round it says "\\Dragon is not accessible. Access is denied." Firewalls are off on the Xp machine. As far as I can tell there is no firewall on the Me2000 pc. The notepad cannot access the intrernet either.

Any more help would be appreciated.


  LastChip 11:04 13 Nov 2005

I, like our Forum Editor, am reluctant to post Registry Hacks, because they can go wrong - Big Time, but sometimes, it is the only way to overcome a problem. So please read this with care and follow the instructions precisely.


First: Go to Start; Run; and type; regedit [OK]

Navigate to;


and look for a DWORD restrictanonymous and see what the value is. If it is anything but 0 (zero), close regedit to follow the next part of this post. If it IS SET to 0, this post no longer applies and it isn't the root cause of your problem.

Next, go to System Restore and make a backup of your system, in case things go wrong.

Now, reopen regedit and as a further backup, go to Registry (top left) Export Registry and save a copy of your registry to the root drive (C:). This is a further safety net should the need arise. I don't wish to frighten you and with this hack, things shouldn't be a problem, but you can't be too cautious when dealing with the registry.

Finally, navigate back to restrictanonymous (as above) RIGHT CLICK the DWORD, select MODIFY and change the decimal value to 0 (zero).

A further word of warning, there is a DWORD restictanonymoussam just below the one you want - DO NOT change this.

Now close regedit and reboot your computer with your fingers and toes crossed ;-) and all should be well

  dragondelboy 11:17 13 Nov 2005

Hi, which machine Xp or Me, or both?


  LastChip 11:23 13 Nov 2005

XP machine only.

  dragondelboy 11:23 13 Nov 2005

Hi, have looked in both registries and neither have a restrict ananymous.


  LastChip 11:31 13 Nov 2005

you first navigate to;


and then look for;


which should be in the right hand window of regedit.

Please confirm it's not there.

  LastChip 11:38 13 Nov 2005

Highlight Lsa in the left window, to see the listing in the right window.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

iMac Pro review

25 book design and illustration tips

iMac Pro review

Idées cadeaux pour geeks et tech addicts