Will not connect to the internet. Virus/Trojan?

  peterleemaxwell 17:54 29 Jun 2014
Locked

I have a strange one. My PC laptop will not connect to the internet although the icon suggests it's connected with an excellent signal. This is working as I am on it with my desktop at the moment. As soon as I try to connect with any programme to update or try to refresh my anti-virus it will not connect stating there is no connection. My son-in-law says it the same as he has got and is a RP Trojan. As I'm not up to speed with this is there anything I can do? Maybe they should if possible hand out prison sentences to all that create these menaces. Help appreciated.

  hiwatt 21:44 29 Jun 2014

Try rebooting the laptop and even the router.Sometimes this has worked for me.Also try going to start/command prompt right click and type ipconfig /flushdns

  hiwatt 21:45 29 Jun 2014

Right click command prompt and choose run as administrator and then type ipconfig /flushdns(note the space)

  peterleemaxwell 21:58 29 Jun 2014

Thanks hiwatt I'll try that. I have been trying various things and have messed the connection up by disabling something as to connectivity. I will try to get back to where I was.

  peterleemaxwell 22:12 29 Jun 2014

Back to where it was. I have noticed one thing where there is on a programme a button to update, say 'zone alarm' the button is greyed out. I will next try ' ipconfig /flushdns'

  wee eddie 23:15 29 Jun 2014

Any chance that you have installed a second Anti virus?

  Ian in Northampton 09:16 30 Jun 2014

Did you ever try asking Windows to repair the connection, as suggested previously? It is often that simple - I had the same symptoms as you the other day, and repairing the connection fixed it.

  highside 10:20 30 Jun 2014

I have had similar problems where my desktop will not connect despite a good signal yet my iPhone or laptop will connect, it has always been fixed by toggling my router unlikely though that may be, I believe its an ISP problem

  peterleemaxwell 10:42 30 Jun 2014

Hi wee eddie I'm sure I have only the one and up to now has worked wonders, that is the Zone Alarm programme when it can update. Thanks Ian in Northampton I have tried that and it states there is no connection. I did find that messing about with a few things that a box came up which I should have wrote the text down but didn't, it was closing down in a set time. highside Hi, Do you mean by 'toggling' giving it a good shake/ I'm not too familiar with the term, sorry.

  VCR97 18:54 30 Jun 2014

But wait a few seconds before switching on.

  Ashrich 15:04 01 Jul 2014

Surprised no one suggested a tcp/ip and winsock reset , that usually sorts things out . peterleemaxwell , if things still aren't working try this ....click on accessories , then right click on Command Prompt and select Run as administrator .

In the black box that comes up type in ( without the quote marks ) " netsh int ip reset resetlog.txt " then press enter .

At the next prompt type in ( again without the quote marks ) " netsh winsock reset catalog " Again press enter .

The laptop will tell you that you must reboot the PC so type in exit , then type it in again , and reboot , see if that helps you .

Ashley

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

OnePlus 7T Pro review

Kristina Bold is a font based on a stroke survivor's handwriting

The best games on Apple Arcade

Les meilleures séries Netflix (2019)