WiFi Networking - New Laptop

  pcmuppet 13:33 29 Apr 2006

Hi, I have a Netgear Router DG834G to which I have connected a Desktop (Via Ethernet Cable), Desktop - Wireless, Laptop - Wireless. All of these work fine. The wireless network is WEP enabled.

I have a new laptop and have been able to successfully connect wirelessly to the network and have entered the WEP key, Network connection shows a strong connection. Checking the status on this connectio verifies this.

However I can't access the internet on this new laptop?

I have manually assigned the IP address as this helped connect to the netgear router and all other settings are as per my wireless desktop. IE has been left at default settings accept use auto-config script and the IP addess in LAN settings.

In Windows Explorer Network settings on the new laptop I have made the wireless connection the top priority, the only other connections are a 1394 connection (fireware) and a Local Area Connection which is showing as network cable unplugged. I have tried disabling this connection but that does not help either.

N.B. If I connect the laptop via ethernet its fine and IE works!

Any help would be great as this is proving very frustrating!!!!!!


  BurrWalnut 14:27 29 Apr 2006

Have you removed the tick from "Never dial a...." in Internet Options, Connections Tab?

  ScarFace(M.O.D) 14:32 29 Apr 2006

have u tried it without firewalls?

  pcmuppet 06:54 30 Apr 2006

Thanks to BurrWalnut and Scarface for your suggestions.

I have tried both of these without success. However on running a network traffic check from Windows XP it would appear that the wireless connection is not being used by the laptop for some reason even though its first in the order list?

  mgmcc 08:16 30 Apr 2006

Try deleting all of the wireless profiles, scan for "Available Wireless Networks" and set up your connection again.

However, I would also revert to DHCP for the IP addressing because, although the fixed IP address may have let you get connected, it could be masking the fact that adapter and router aren't communicating properly. With DHCP it will either get its "192.168" address from the router, so you know they are talking, or it will fail and default to a Windows APIPA "169.254" address which won't connect.

  pcmuppet 10:31 30 Apr 2006

Thanks mgmcc.

I couldn't delete the profile, however I did remove the IP address and allow DHCP to find one. I also removed the DNS addresses from my ISP.

As you said, this has resulted in the connection not being able to acquire an IP address and it has defaulted to Windows which won't connect.

This is surprising as the signal strength is "excellent"?

I am sure that I added the new laptop has been to the list of trusted sources as far as the router is concerned but will check this.

  pcmuppet 10:38 30 Apr 2006

Have just checked the MAC address and this has been added to the list of trusted wireless stations allowed by the router.

The new laptop still can't acquire an IP address even though the signal strength is excellent.

  maiden7802 11:47 30 Apr 2006


I'm not techie so I'm not sure if this is relevant or not but my laptop suddenly stopped connecting to the internet. This a reply that I got which sorted it for me. . . . .

bring up a command prompt window . Type in IPConfig and follow it with a space / renew. So the command should look like : c:\ipconfig /renew this should force your router to issue a new ip address. You can check if it has done so but just running ipconfig on it own afterwards.

You get to tcp\ip properties as follows:

Control Panel
Network Connections
Right click on the connection showing there
pick properties
On the general tab half way down it should say something like : this connection uses .... and then a list of stuff. Internet Protocol (TCP\IP) should be there, normally at the bottom of the list.
Highlight it and click properties again.

On the next window on the general tab it should have two sections: Obtain IP Address automatically and Obtain DNS automatically, this is the section which obtains the ip address from your router. If it isnt working you can put a manual address in by clicking on the appropriate radio button.

I found it also a good idea to temporarily turn off your firewall on the machine you have the problem with, if you are using a software firewall on each machine, as sometimes they do stop an ip address being obtained. Once its working ok you cannturn the firewall back on and test again

  mgmcc 12:15 30 Apr 2006

<<< The new laptop still can't acquire an IP address even though the signal strength is excellent. >>>

It doesn't matter how good the signal strength is if you haven't "Connected" (as in "logged in") to the Wireless Network. It is only then that the adapter can gets its address from the DHCP server.

I would suggest that, until you get the new laptop connecting properly, you disable both WEP encryption and MAC address filtering.

  pcmuppet 13:01 30 Apr 2006

Thanks to maiden7802 & mgmcc for you comments.

I have now switched off the trusted sources on the router, XP firewall and WEP security and I can now connect!!!!

I have since switched the firewall back on and then the trusted sources and it still works, must have been the WEP security even though I had the right key.

Thanks again for the help, will now try out WPA security instead!!!!!

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

AMD Radeon Adrenalin release date, new features, compatible graphics cards

Artist Pete Oswald on creating relatable characters & his new book

New iMac Pro release date, UK price & specs rumours

Idées cadeaux pour geeks et tech addicts