Wifi network adapter randomly gets limited connectivity and freezes

  Poor_sod 12:16 25 Apr 2013

I'm having a really annoying problem which is making my laptop almost unusable and a hassle to use. After a while of my laptop being on, my wireless network adapter will suddenly get "limited connectivity", and won't connect to the internet.

Disabling and enabling the adapter will cause my computer to freeze, requiring a restart. The same with troubleshooting. The only thing which fixes this is a fresh reboot, however it always occurs again within the hour.

Sometimes the entire adapter will randomly just disable itself, and the computer will completely freeze, meaning I have to press the power on/off. Sometimes the adapter will just disappear from Device Manager. Searching for "plug and play" devices will cause it to freeze.

Apart from having to reboot, what also seems to work is disabling the wifi from PC Settings, putting the computer to sleep, then awaking it and turning wifi back on. I've had to do that 6 times whilst typing this post.

I've tried flushing my dns, registering it, renewing and releasing. Assigning a static DNS address. All those things. Though I may have done them wrong.


[B]Laptop model: [/B]Samsung RV511 (i5) notebook from around 2010 4GB RAM, Intel(R)Core(TM) i5 CPU M [email protected] 2.67GHz

[B]Operating system[/B]: Originally came with Windows 7 64bit installed, issue began on this. I installed Windows 8 64bit Pro a month ago, did not reset settings. Problem persists

Broadcom 802.11n wireless network adapter Device ID 4727 Driver date: 13/03/2012 Driver:

It's the latest driver according to Windows. I keep uninstalling the driver and installing random ones from 2006, 2011 etc however the same problem persists.

I've tried uninstalling the driver and just rebooting, but problem still comes back after a while.

  mgmcc 10:37 26 Apr 2013

Are you able to get your hands on a USB WiFi adapter to see if that also has the same problems?

It might also be worth checking to see how the Laptop behaves if you connect it to the router with an ethernet cable and disable WiFi.

  rdave13 13:08 27 Apr 2013

Try this. Go to device manager, right click the wireless adapter, select properties and under the power management tab make sure all boxes are unticked.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

iMac Pro review

The City of Los Angeles graphic designer job ad amuses internet

iMac Pro review

Les meilleurs smartphones Android (2018)