Wifi connection issue with laptop

  SamParfitt92 17:56 02 Nov 2015


I'm currently experiencing an on-going issue with my laptop. I randomly lose connection to the internet multiple times a day, once this happens my laptop then fails to pick up any signals whatsoever. If I'm listening to something or watching a video, the sound will start to skip and crash when this happens and the cursor will also skip around the screen.

I know the issue is not the internet/modem because it's only started doing this recently, sometimes it happens after 5 minutes...other times it can go an hour without happening. I also have other devices connected to my internet so again, I know that the internet is fine. If I turn the laptop off and back on again, the internet is working fine, but can go off again at any time, so I know the issue is with the laptop, especially with it not picking up any connections at all when it happens, not just mine.

Anybody had any issues with this? I can't seem to find anything online that is of similar situation, it seems to be an issue with the laptop but is it a hardware issue or something that can be fixed in the system itself?

It's beginning to get really annoying having to constantly restart my laptop just to get the internet back on for maybe 20 minutes, especially when I have work to do.

Thank you.

  Govan1x 18:10 02 Nov 2015

Are you connected by Ethernet or Wireless.

And have you tried switching the Modem/router off for 10 seconds and then on again to see if that clears it.

  SamParfitt92 18:16 02 Nov 2015


Well the router has been off yes If i have had any issues generally, but as I stated its a laptop issue, not router as it doesnt effect other devices/computers.

  Fruit Bat /\0/\ 18:41 02 Nov 2015

Perhaps your computer is switching off the wireless card.

Device manager - right click the wireless card - properties - power tab - untick "Allow the computer to switch of...."

  SamParfitt92 20:59 02 Nov 2015

I found three different adapters that said "turn off to save power" and they were all ticket so I unticked. hopefully that sorts it

  SamParfitt92 00:46 03 Nov 2015

I thought the device manager trick had fixed it, it was fine for about 3 hours but it's just gone off about 5 times in 20 minutes.

I'm lost for options it's beginning to become very annoying

  SamParfitt92 16:34 05 Nov 2015


This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Huawei MateBook X Pro review

8 digital brands that designed custom typefaces to save millions

How to speed up a slow Mac

Comment résoudre des problèmes d’impressions ?