Wifi Compatibility issue with WPA-PSK.

  DJ-Garry 12:05 23 Oct 2013

Hi guys :)

My son has just bought a new desktop PC online. It's a Cyberpower Gaming Battalion 502 PC - AMD QC FX 4350 4.2GHz - 8GB RAM + 2TB HDD + DVDRW - AMD Radeon HD7770 - Windows 8 64bit

It got delivered to my house and he came round to set it all up, and everything worked just great. It doesn't have a wireless LAN card in it, so we hooked it up via cable to my Virgin Media cable wifi router, did all the system set-up and product registration. Then, because his bedroom where he lives does not have the router or modem in it (the still use Virgin Media ISP), we installed a small wifi dongle so he could use it where he wanted. In fact, it installed itself. It was one I had lying around from a previous project, we popped it in, and Windows 8 seemed to recognise it and reported it working correctly within just a few seconds.

Here, at my house it worked fine, roughly the same 10meg speeds as when on the cable hookup. (checked via speedtest(dot)net) I have a Motorola cable modem and an AirStation wireless router, running 802.11g WEP. He has a similar modem, but Virgin has given them a Belkin router, and they are running 802.11n WPA-PSK.

The dongle is both g and n compatible and he gets good signal strength here and at his house, but when he's at his house he gets internet speeds slower than a 56k dial-up modem, even basic pages take tens of minutes to load, if at all. Also in their house (and here too) there are various other devices capable of being connected to the wifi, including iPhone, iPads, Android devices, gaming consoles, and laptops ..... some Windows 7, and some Windows 8. All were disconnected to check if was a local bandwidth issue, but no change.

I have read of some weird compatibility issues with Windows 8 and WPA-PSK, but the laptops seem to be great with it, or is it that's the dongle is a couple of years old .... did older dongles not like WPA-PSK security?

I don't live with my son, I have no access to inside his house, and I don't get on at all with his other parent, so any changes that can be made to his desktop would be appreciated first, rather than me have to talk him through a router reconfiguration, even if he does get permission to do it given his mother's paranoia that I'm trying to hack into their home network ..... if you understand me :/ lol

H E L P !!!!! please :) Garry.

  DJ-Garry 22:50 23 Oct 2013


  Secret-Squirrel 08:53 24 Oct 2013

I haven't encountered any, nor heard of any problems with WPA and Windows 8 so I think we ought to look elsewhere for the cause.

The first thing you should get your son to try is to update the drivers for the USB wireless adapter:

1) Go to Control Panel -> Device Manager -> "Network Adapters" section -> double-click the wireless one -> "Driver" tab -> "Update Driver" button. Choose the option to "search automatically" which includes Windows Update on the Internet.

2) Visit the manufacturer's website and download the latest Windows 8 drivers (if available).

If at all possible, temporarily connect the PC via Ethernet cable before attempting the above.

  Woolwell 11:13 24 Oct 2013

If it worked well in your house then it points to a location/router problem and I don't think that updating the drivers will greatly help. He could try changing channel on the router. Has he had good connection in that location before? You may need to consider something like Homeplugs.

  Secret-Squirrel 11:52 24 Oct 2013

"If it worked well in your house then it points to a location/router problem"

Yes, it worked well in Gaz's house but the router there was using WEP and not WPA which is what's being used at his son's home. I doubt that it's a location problem as his son's computer is receiving good signal strength. I can't see how it can be a router problem because every other wireless device is working fine.

On some occasions I've found that simply updating the wireless adapter's drivers fixes issues like this so it's definitely worth trying.

  Woolwell 12:52 24 Oct 2013

g and n differences?

  Jollyjohn 13:25 24 Oct 2013

I have a very old USB wireless dongle that cannot handle wpa-psk and therefore will not connect to my netgear router.

Try a modern dongle - I got a tp-link dongle from PC World and it works fine. click here

  woodchip 15:21 24 Oct 2013

Is His Laptop a Toshiba by chance as I got one some years ago from Curries and took it back as it would only connect by Wep

  Woolwell 15:23 24 Oct 2013

Woodchip - From first post - it is a brand new desktop.

  woodchip 15:26 24 Oct 2013

Sorry but if its HP it may use the same F Keys

  woodchip 15:27 24 Oct 2013

I see it does not say HP. But he needs to take care when pressing F keys

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Samsung Galaxy S9 review

Wacom Cintiq Pro 24 and 32 review – hands-on

When is the next Apple event?

Gmail : comment annuler l’envoi d’un e-mail ?