Why are my drives not available?

  Newuser3068 16:16 26 Jan 2005

I run Windows XP SP2 home edition.
I recently discovered that my CD-R drive was not functioning. I have now discovered that, in addition to this, my floppy drive is not available and a USB storage device I have bought is also not available.

Here's what happens:-

1. If I put a CD into my D: drive (a combo DVD/CD-R drive), none of the data on the CD is recognised. Windows Explorer sees the drive, but if I try to read the files on the CD, Explorer finds nothing at all. I have tried this with several CD's, some home burned and some commercial software CD's. They all behave the same.

2. If I hot-plug my new 1GB USB storage device into a USB port, again Windows Explorer finds the drive (E: Removable Disk) but if I try to drag-and-drop files on to it, I simply get an error report telling me that the drive is not available.

3. If I try to drag-and-drop files to my A: floppy drive, I get exactly the same as 2. above.

My printer is a USB device and that is working. My hard drive (C:) seems to be working fine.

Some people have told me to reinstall Windows, but how can I do this is my CD drive won't work?Can anyone tell me what's going on, and how to solve the problem, please?

  ACOLYTE 16:19 26 Jan 2005

have you tried removing the drives in device manager and restarting windows should find them again and reinstall them,also you could try updating you mobo drivers.

  Djohn 16:20 26 Jan 2005

Can you pinpoint as to when this started? Have you by any chance downloaded or updated anything around the time your drives became unusable also have you been into your BIOS for any reason?

  Newuser3068 16:50 26 Jan 2005

Acolyte - thanks for the idea. I'm not familiar with the term "mobo" - are you just saying "device drivers"?

Djohn - no, unfortunately I can't pinpoint the trouble to any particular event. Trouble is I hadn't used my CD drive for a week or two prior to discovering its problem. Then, bit by bit, I discovered the other problems as I came to try and use those drives. I certainly haven't been mucking about in the bios.

  Stuartli 17:42 26 Jan 2005

Have you checked out the drives' Properties in Device Manager and ensured that they are Enabled and working correctly?

If they are not listed, go into Safe Mode and then Device Manager again for a second check.

If the drives are now listed, then the most likely cause is loose or dislodged cables or leads; check them out for tightness. It's particularly relevant in the case of a floppy - loose, wrongly fitted or damaged leads are a key cause of floppy drives not working.

One other possible cause of your CD drive not working is a laser which has given up the ghost.

Mobo is short for motherboard and ACOLYTE is suggesting you may need to reinstall your mobo drivers.

  Newuser3068 18:16 26 Jan 2005

Yes - all the drives are listed and working properly in Device Manager. However, I will look again in Safe Mode - what's the difference when you do this?
I'll also check out all cables for proper location.
I tend to feel that a physical problem in the CD drive is unlikely, given the two other problems completely independent of the CD. Would you agree?

  Chezdez 18:20 26 Jan 2005

have you tried the flash drive in both USB ports, might just be a faulty port. same with the printer, try both ports

also, try the drive on a different computer

for the CD drive, how old is it? has it just bitten the dust? perhaps a badly scratched disk was last in the drive?

  Fruit Bat /\0/\ 18:24 26 Jan 2005

Re-enable DMA using the Registry Editor

Run REGEDIT. Go to the following key:


It has subkeys like 0000, 0001, 0002, etc. Normally 0001 is the primary IDE channel, 0002 the secondary, but other numbers can occur under certain circumstances. Check the DriverDesc value to see which one it is.

Delete MasterIdDataChecksum or SlaveIdDataChecksum, depending on whether the device in question is attached as master or slave, but it can't actually hurt to delete both. Reboot. The drive DMA capabilities will be redetected.

Open Device Manager again and check whether the device is now actually using DMA mode. If so, congratulations, you've made it (at least until the next time Windows disables DMA).

Alternative Method—Uninstalling the Port
1. Uninstall the secondary IDE port
To do that, open Device Manager as follows. Right-click on My Computer, select Properties, click on the Hardware tag, click on the Device Manager button, click on the plus sign to the left of IDE ATA/ATAPI Controller, right-click on Secondary IDE Channel, click on Uninstall. Deactivating is not enough.

Reboot to make the changes active and permanent.

After booting Windows will automatically reinstall the IDE channel and the DVD (or CD) drive. This Plug-n-Play process can take a little while, so give it a minute after the boot process finishes.

2. Reactivate DMA
But this is not enough, because unfortunately Windows does not automatically activate DMA on a DVD or CD drive. You have to tell Windows to try to use DMA first.

For that, go to Device Manager again. Right-click on My Computer, select Properties, click on the Hardware tag, click on the Device Manager button, click on the plus sign to the left of IDE ATA/ATAPI Controller, double-click on the secondary IDE channel, click on Extended Settings and change the relevant setting from PIO only to DMA when available.

On Windows NT and 2000 you now have to reboot a second time, but Windows XP applies the change instantly. Then you can go to the same place in Device Manager again and check whether the device is now actually using DMA mode. If so, all is well.

3. Driver is not intended for this platform
If you keep getting the following error message:

There is a problem installing this hardware.

IDE channel

An error occurred during the installation of the device. Driver is not intended for this platform.

then the way out is to rename C:\WINDOWS\system32\drivers\atapi.sys (or a similar path on your computer) to something like atapi.old.

If that's not possible, you can try it from the repair console (boot from the Windows install CD and select the repair console).

  Stuartli 09:24 27 Jan 2005

Re Safe Mode and drives being listed, although not in Device Manager in normal operating mode - I don't know why this is so, but it occurs (usually) if a lead or cable has been dislodged or becomes loose.

It can happen when working/installing components inside the case.

It happened to me last year, for instance, after swapping a Celeron for a Pentium CPU and my drives suddenly disappeared; they were not listed in Device Manager except in Safe Mode.

I eventually discovered that one of the IDE cables had been partially pulled out of its motherboard joint socket at a slight angle, but was difficult to spot.

Once pushed back in firmly the drives "reappeared" and subsequently worked properly...:-)

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

iMac Pro review

Illustrator Charles Williams on how to create magazines and book covers

iMac Pro review

Les meilleures prises CPL (2018)