WB 6400AAK Ext USB drive troubles

  NickyK 20:39 21 Apr 2010

I have tried search but didn't find a solution that fitted.

I have a 640gig Western Digital "Elements" (WD 6400AAK) and up until now it has been fine. However, when I switch it on now it fails to appear on My Computer page (on Dell Dimension 2400 XP SP2 & 3)and no autoplay window appears (the other externals are fine) so I can't get into it. Yet the blue light flashes happily, it makes the usual sound and it is listed in Device Manager (when connected and on, obviously) ass "working properly". It also makes the usual "Plink plonk" chime when switched on and the "Safely Remove Hardware" icon appears in the system tray. I've tried reinstalling it, changing USB cables, I even changed the fuse in the power plug.

  mgmcc 21:03 21 Apr 2010

Go into "Disk Management" (Start > Run, type DISKMGMT.MSC and click OK) and see if it is shown correctly in there.

Disk Management may show the drive as not having a drive letter and needing to be formatted, which is not unknown with external USB drives. Formatting will destroy the data already on the drive.

  NickyK 21:23 21 Apr 2010

Thanks mgmcc (sorry I had a typo in my topic headline). The WD drive does not appear in the top space of the DISKMGMT result (though the C: drive and an external I have on do appear). The problem drive seems to appear in the lower "itemized" section and it is described as 596GB on line but unallocated and with a black bar across this mini-window area. Not listed as a partion with a blue bar. I would obviously prefer not to lose the data on the drive.

  Fruit Bat /\0/\ 21:31 21 Apr 2010

Try testdisk click here

  NickyK 21:46 21 Apr 2010

Thanks Fruit Bat. However, I am not sure what to get from the page you suggest!

  NickyK 21:52 21 Apr 2010

Okay. Tried that. Although my WD drive is listed in device manager, it won't autoplay and therefore it can't be found by any diagnostic tools or by simply typing G:\ in Run (I know it is G). How do I access what my PC refuses to allow me to find in any place other than device manager under "Disc Drives"? The PC recognizes its existence, yet it won't "run".

  Fruit Bat /\0/\ 21:57 21 Apr 2010
  NickyK 22:37 21 Apr 2010

Tried that as above. Thanks. No luck. I need to access the drive. It is here, it is recognized on Devide Manager, yet it won't autoplay so I cannot get into it!

  NickyK 17:02 25 Apr 2010

Eventually solved this strange problem by running a little partition recovery program. I used the "Recover lost/deleted partition" thingie. It found the partition. I then gave the drive a new "letter" and clicked "apply". Much to my amazement, the drive was back, fully accessible with no data lost at all! Blimey!

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Samsung Galaxy S9 review

Wacom Cintiq Pro 24 and 32 review – hands-on

When is the next Apple event?

Qu’est-ce qu’Amazon Prime ?