W7 Network Problem

  onthelimit1 09:02 31 Aug 2012

My main PC is Windows 7 pro, with a USB connected Brother printer. My other, is an XP machine working through homeplugs in the workshop. I had set this up to be networked and printing to the Brother printer was fine. It suddenly stopped printing – looking at the W7 Control Panel, Network and Sharing centre, Change Advanced Sharing settings, it is set to Turn Off Network Discovery and Turn Off File and Printer Sharing. I can click ‘turn on’ and then ‘save Changes’, but when I go back to check they’re both at Off again.

Google seems to suggest a repair install of the OS. Wondering if anyone has other thoughts before I do that.


  difarn 10:38 31 Aug 2012

Trying going into start - typing Services - then scrolling down to see if Server is still enabled. Server Services may, for some reasons, have become disabled.

If the problem persists you could try a system restore.

  onthelimit1 12:23 31 Aug 2012

Thanks again, difarn. services on auto and are running. will try a system restore and report back (have tried sfc /scannow, which found no corrupt files).

  onthelimit1 17:28 31 Aug 2012

Restore did not help. I then turned off Windows firewall and the file and printer sharing is now enabled! So, it's a problem with the firewall (which I want on), but I don't know what yet.

  onthelimit1 17:37 31 Aug 2012

Finding a thread on Google on this subject, I've found that under Inbound Rule Wizard in firewall, the predefined Rules box is greyed out. The thread suggestion was that this could be caused by a virus. My problem is how to get it back, as I can't follow the thread solution shown here, so perhaps a repair is the only option?

  difarn 18:10 31 Aug 2012

Apparently this can also be turned off by another security suite that also includes a firewall.

This article may interest you and explains how to reactivate - I am assuming that there is text that is greyed out in the boxes for reactivating. You say that your Rules box is greyed out - is this empty?

You could try running the free malwarebytes to see if there was a virus.

This provided a solution on one forum:-

Go to windows firewall in control panel

On left side,click on Advanced settings

On right pane,click on Diagnose/Repair

Select shared folders and home group and troubleshoot it.If windows doesnt find any issues with them

You may have to restore default policy of your firewall

Click on Restore default policy

  onthelimit1 20:37 31 Aug 2012

Thanks difarn. People round tonight, so will give it a go in the morning.

  onthelimit1 09:37 01 Sep 2012

Hmm - on the right track -

'Windows firewall is incorrectly configured'. After attempted repairs 'windows could not etc etc' and 'could't restore default policy'.

So, does look like a corrucpted registry. Think I'll have to bite the bullet and try a repair install (which I have not done before on W7).

  rdave13 13:45 01 Sep 2012

Try setting the firewall settings to default, click here

  onthelimit1 15:33 01 Sep 2012

Thanks rdave. Tried that but no change. think I may have to think again about a repair install - info I found suggests I can't do that if the OS was preinstalled (OEM), even though i have a W7 DVD. Problem with the COA apparemtly. Any thoughts?

  rdave13 16:04 01 Sep 2012

Before going down the repair route have a look at the free version of Sphinx Firewall control. Not the portable one. When I ran it, it gave some control over what programs could do or not. Worth trying out.

Have you ran sfc/scannow a few times? That could also help. Sometimes repair (reinstalling over the top) can cause more problems but if it's the last resort then you'll have to consider it.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

iMac Pro review

Illustrator of witty, relatable Instagram comics Julia Bernhard touches on our humble moments

iMac Pro review

Quelle est la meilleure application de podcast pour Android (2018) ?