W7 laptop - no wireless connection to printer

  onthelimit 13:20 17 Dec 2010

Compaq laptop, HP 309g printer, Thompson router.

Set it up last weekend and all worked OK. She rang 2 days later to say no print. Printer showed as 'off-line'. Uninstalled software and downloaded up to date version. Installation went OK until wireless where message 'cannot connect etc...check firwall...' Prints via USB OK. Printer Config Page shows it as connected to the router with an IP address of - config source DHCP.

Any ideas, please.

  onthelimit 17:52 18 Dec 2010


  Jollyjohn 12:03 19 Dec 2010

In control panel right click on the printer and select properties.
Under ports check the printer is on the correct port. You will have to make the column wider to see the ip address of the port - tick the box with the correct address and the printer will appear online.

  onthelimit 14:33 19 Dec 2010

Thanks - I'll have a look next time I'm there.

  oarenchina 05:08 29 Dec 2010

Hi buddy,

I know only too well your feeling about the headache, since I am right on the way to crack the HP 309g printer.

I'm not entirely sure that I have the correct model, but I think it's an HP photo-smart premium 309g, using a network connection. It was working fine on my Ubuntu 9.10 install before, but one day it failed with the message "cups-missing-filter". I accidentally deleted it from the list of drivers. Now, whenever I run a tool to install it back, it hangs at "searching for network printers".

Anyway, really hope someone help you and me get us out of the hook?

Good luck!

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Best Amazon Echo: What’s the best Alexa speaker?

Kano Computer Kit Complete review: A fun DIY 'laptop' that teaches kids to code

Best pro photo editors for Mac 2018

TV & streaming : comment regarder les Jeux olympiques d’hiver 2018 ?