W32/Virut.Gen Virus - Really struggling with this.

  MrSheen 12:19 01 Jun 2010


I use Avira Anti-Virus software, and today it displayed an error and shut down. When I tried to re-open it, it said something about the initialisation of the modules and CRC or something. I didn't write it down.

I downloaded the latest .exe file from their site and re-installed, when it scanned, it found the W32/Virut.Gen virus, and then things went downhill.

I did a full scan with Avira, Malwarebytes and Spybot Search & Destroy. When they'd all finished and done their thing, I rebooted as they said some files would be removed upon reboot.

Now when it boots up I get my desktop background, but nothing else. I can access Task Manager, but there's no C:Windows/explorer.exe file so I can't get the taskbar back.

I've opened up Spybot and am re-running that, but am getting the annoying system beep that Avira uses when it detects something dodgy. This is going off every 2 seconds, literally. Needless to say, I've left Spybot to do it's thing.

There's no process showing in task manager that has anything like "W32/Virut.Gen" as some of the forums have said to end this process.

If anyone could shed any light or point me in the right direction to sort this out, I'd be massively thankful. I really don't want to have to re-format the hard drive again, as I only did it a few months back.

Thanks in advance.

  gengiscant 13:25 01 Jun 2010

It's a start, have a look here. click here

  MrSheen 13:39 01 Jun 2010

I've tried a few of the removal techniques on Google already, but a lot of them tell you to disable system restore 1st, which I can't do as I don't have access to my Start Button/Taskbar and it seems my permissions have been altered so I can't even open Task Manager anymore.

  provider 2 13:46 01 Jun 2010

It looks as if this one will require specialist help at the very least, and you may end up reformatting anyway (Bleeping Computer): click here

  birdface 13:47 01 Jun 2010

Try in safe mode and see if it works better from there.

Norton removal Tool but have never tried it.

click here

Could be you may need to reformat.

Some keyboard shortcuts that may help.

click here

  mimosa418 15:08 01 Jun 2010

My experience with Virut was awful.Nothing I tried completely removed it and the OS gets wrecked in the process.
I eventually removed as much as possible then reformatted the drive and reinstalled the OS.
That had to be repeated twice before the sod eventually stayed away.
best of luck.

  MrSheen 15:13 01 Jun 2010

Well, now its asking me for a password to get into Windows, my admin one isnt working, and when i leave the field blank, it lets me in, but instantly kicks me back to the password screen again. it's the same in safe mode too.

Don't know how I'm going to get in there to back-up my stuff now. Might give the local mobile pc doctor a call. otherwise i'll spend days trying to sort it out on my own.

  onthelimit 15:47 01 Jun 2010

To get back in, you could use a Knoppix ISO CD (free download)which will boot from the CD, by-passing windows altogether. You may then be able to transfer data to a flash drive. This CD basically runs a Linux operating system.. I've done this twice now, with total success. If you need more info, feel free to contact me through the yellow envelope

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Sea of Thieves Review

Dell Canvas review: the cheap Wacom Cintiq alternative

How to use iMovie for Mac, tips and more

Comment filmer l’écran d’un iPhone ?