w2k networking

  stephenbux 19:57 05 Mar 2004

I am trying to connect 2 PCs using a rj45 patch cable and 2 network cards, both cards are working. I seem to have a problem with TCP/IP on one of the machines, when I use the command prompt ping it tells me it does not recognise the command, the other machine recognises the command. I have uninstalled TCP/IP and reinstalled it, rebooted and still the same problem. Any ideas please.

  spikeychris 20:08 05 Mar 2004

X-over cable?

  stephenbux 20:27 05 Mar 2004

I am using a x-over cable (patch cable)

  Taran 21:00 05 Mar 2004

Do this on each machine:

Click on Start, click on Run and type cmd then click OK.

Assuming the Command Prompt window opens up, type this:


then press the Enter key.

Do that on each machine and not the space between the word ping and the IP address of

That address is a loopback ping and it tests TCP/IP functionality on the machine you run it ot, so you don't need a network cable attached for it to work.

If you get a successful return of all four data packets then at least TCP/IP is initialising properly and we can move onto soemthing else.

Post the results after you try the above on both machines.

  Taran 21:03 05 Mar 2004

"not the space between the word ping..." should obviously have read "NOTE the space..."

Sorry about that - my fingers are stuttering this evening.

  LastChip 21:19 05 Mar 2004

you are saying something that is contradictory.

A patch cable is a straight through cable, and if you are making a direct connection through the network cards, it will never work.

Do yourself a favour, and confirm you have a crossover cable. Most cables these days are transparent to some degree at the plugs. Hold them to the light, the same way around and confirm two of the wires are transposed to their respective pins. If both plugs have the wires ordered exactly the same, you do have a patch cable and will need to change it.

Please confirm that before we all continue.

  Taran 21:43 05 Mar 2004

I'd still like to know the results of the loopback ping, just to see if TCP/IP can be initialised on each machine. It will rule out a possible software fault.

I agree that the cable is normally the first thing to look at in terms of hardware faults or just being the wrong type of cable for the job, but I'm a bit concerned over the 'command not recognised' message on attempting to ping.

  stephenbux 08:11 06 Mar 2004

Taran, The ping command works on one machine only, the other machine reports that 'ping' is not recognised as an internal or external command, operable programme or batch file.

  Taran 12:55 06 Mar 2004

OK, on the machine that is not recognising the ping command, try this instead:

Cilck on Start, click on Run and type in this


the click on OK or press your return key.

I expect you'll get an error trying to launch ping this way as well, but if you do it will help me diagnose things for you.

Assuming you get an error or nothing happens, search in your WINNT\System32 folder[Windows\System32 on XP ] and see if you can find the ping.exe program file. If it's there, great, if not we can extract it from your WIndows CD.

Assuming that the ping.exe program is in the System32 folder, try this:

1. Right click on My Computer

2. Left click on Properties

3. Click on the Advanced Tab

4. Click the Environment Variables Button

5. Look in the system Variables List for "Path"

6. Select the "Path" entry then click the Edit button

7. Look for this string:


If it's there, it should read:

Likewise, you may find an entry like this:


If you do, change it to the absolute path of your Windows root folder which, on Windows 2000, should be c:\winnt
Post back with the results. I suspect that your Environment Variables are having a bad hair day.

  stephenbux 15:18 07 Mar 2004

I did wnat you suggested- regarding the path statement, it worked. I have now managed to ping the cards, they are functioning as they should. I have now managed to configure both machines and the LAN is working fine, many thanks for your help.

  SEASHANTY 16:31 07 Mar 2004


This thread is now locked and can not be replied to.

Elsewhere on IDG sites

HP Envy x2 review: Hands-on

Iconic New York graphic designer Milton Glaser on his uplifting new subway posters

New iMac Pro release date, UK price & specs rumours

Comment suivre le parcours du père Noël ?