Vista SP2 users. Anyone care to check on this.

  mooly 19:48 30 Jul 2009

Found this by sheer chance, due to another thread I posted earlier on Vista's defragmenter. Someone asked how to disable it.
Problem. I find Vista's own defragmenter will not open from within windows. Type defragmenter into the search/run box and it won't open.
If you look in services> (type services into run box) and scroll down to "task scheduler" it should say "Automatic". If you double click it (this won't alter anything) and look under the general tab all options in my case are greyed out.
Google to the rescue,
click here
which has worked.
I am trying to piece together a couple of seemingly unrelated problems, this, a windows update error problem that MS are aware of, and although they have a fix that always works the problem recurs.

  gazzaho 21:04 30 Jul 2009

Thanks for the posting, I don't use task scheduler or windows defrag myself but I just checked this out and it's true that all options in the task scheduler services are greyed out and running defrag appears to do nothing but show the UAC screen.

I have a drive set up, which I can choose from bootup by tapping F8 at the appropriate time in the boot process, which I use to test updates and the like before applying them to my main drive. On trying the .reg file you supplied the link to on this test drive it doesn't appear to have fixed anything, other than perhaps allowing the computer to run the service on startup on machines where the service has been switched off. On my test drive the task scheduler service is set to automatic but I'm still unable to alter any settings and the defrag still doesn't appear.

Did the "fix" allow you to alter the task scheduler service settings or allow defragmenter to work after you applied it?

  Woolwell 22:17 30 Jul 2009

Although the task scheduler options are greyed out defragmenter runs.

  mooly 06:53 31 Jul 2009

I discovered this through somebody asking "how to turn off Vista's defragmenter". Like you I don't use it as such, I run it from a command prompt however,
I made a back up first, and applied the registry fix, and it worked, reboot and defragmenter opens normally. Task scheduler options were still "greyed out" however.
Tried this AM after a full shutdown overnight and NO defragmenter.
I am going to try and find out more on this if I can.

  gazzaho 00:37 01 Aug 2009

Hi mooly, I've tried defrag from the command prompt and it does seem to be working, but there's no indication it's doing so from within Windows. I know it's supposed to run in the background, and as I say I haven't used it for quite some time, I tried it once and I do remember some form of notification in Windows that it is running although I can't remember exactly what. It would appear that the "GUI" part of dfrgui.exe has decided not to play ball.

It does seem to be a problem that others are experiencing however as I've read a few posts after googling it, here's one click here

  Night Ryder 01:39 01 Aug 2009

Well what can I say Vista is dead. Windows 7 will be shipped with new PC's in october this year

  gazzaho 06:57 01 Aug 2009

Say Whaaa? What does your post have to do with the problem we're discussing? Everyone is aware of Win 7 and in my opinion the rip off price for European versions of it. Some people, including myself won't be jumping on the £50 band waggon in order to upgrade, from what I've been reading Americans can pick it up for as little as £30.

I'm wondering how long after the launch before people start complaining that updating Win 7 has screwed my computer up. Knowing the history of MS we won't have a long wait.

  mooly 07:24 01 Aug 2009

Hi gazzaho, I found like you that Google throws up loads of entries for this but no fix that I can see that really works. Have posted the problem on the MS Technet board, no response as yet !
It would be interesting to know for all those folks that just use the "default" settings and who assume the defragger is running, that it really is actually working in the background ?
Have to smile at W7. You think it might have "issues" then ;)

  gazzaho 07:58 02 Aug 2009

This is really strange... I just tried windows defrag again and it's now showing the options dialogue box! I haven't done anything other than rebooted a few times from the last time I tried it.

I specifically rebooted after changing the registry in order to allow the changes to take place and it didn't run as I stated, now it is. Perhaps the fix needed a few re-boots to take properly, the service options are still greyed out however. I think I'll keep an eye on this, just out of curiosity for a while and see if it changes again.

  mooly 11:51 02 Aug 2009

Well I rebooted after the reg fix and as I say, it for me worked in that the GUI opened, and after a couple of minutes came back with "defrag not needed"... as expected.
The reg fix worries me because when you look at it in notepad, to me it's a major bit of code. If you were just changing a value somewhere I would have thought it would have been done as a manual tweak. The fact that it doesn't "cure" the underlying issue of task scheduler being greyed out suggests (maybe) further problems down the line if it does ever get acknowledged as a problem, and a fix, hotfix, or what ever gets issued, which may not then work or cause some other issue.
I made a full Acronis image before applying the "fix" and have gone back to that (can never quite make 10 on the Vista reliability thing, always something happens at 9.9 something... :)) , anyway the defragger not working from Windows doesn't bother me. I didn't back up the registry, as I could never be sure exactly what the "fix" actually does and alters. Still nothing on MS Technet :( never a good sign.

  gazzaho 02:20 03 Aug 2009

I've just re-installed Vista onto my everyday desktop drive, not because of this problem, but because it has been showing symptoms of flaky behavior from I stupidly installed a recommended update from MS for drivers for USB hard drives which caused some drives to become invisible. This update couldn't be removed properly and I had to revert to a system restore which got the drives reconised again, then to compound issues the SP2 update screwed the filters on my DVD writer up for some reason.

The reason I'm posting is that the options for task scheduler are grayed out from the get go in Vista Home Edition Premium SP1, that's the first thing I checked on when I got to the desktop. So the question is what did the fix do? The only thing I can think, and from what I've read on other forums, is what I said in an earlier post, and that is to re-activate task scheduler if it has been shut down and can't be re-activated.

I think I'll do the same as you and restore the registry settings to before the patch on my test drive, as you say you can't be sure what will happen at a later date.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Dell XPS 13 9370 (2018) review

No need to scan sketches into your computer with Moleskine's new smart pen

HomePod review

Streaming : Netflix ou Amazon Prime Video ?