Vista laptop will not install anythinjg

  howard64 09:09 23 Nov 2012

I have been asked to fix a laptop running Vista sp1 which has not installed any updates for about a year. I can copy to the hard drive but nothing will install including a standalone copy of sp2. The ms fix it cannot install so cannot run. I have tried to use sfc but get the message "windows resource protection could not start the repair service". When the pc starts it tries to run checkdisk but cannot with the message "corrupt master file table". I have run Malwarebytes and Superantispyware but the machine appears to be clean. I have now run out of ideas other than a clean install. Can anyone suggest something else to try?

  Fruit Bat /\0/\ 09:27 23 Nov 2012

"windows resource protection could not start the repair service"

  1. Click Start, type Services.msc

  2. Double-click Windows Modules Installer

  3. Set its Startup type to Manual

  4. Click OK.

SFC - To check your Windows protected files, proceed as follows:

1/ Click the Start button

2/ From the Start Menu, Click All programs followed by Accessories

3/ In the Accessories menu, Right Click on the Command Prompt option

4/ From the drop down menu that appears, Click on the 'Run as administrator' option

5/ If you have the User Account Control (UAC) enabled you will be asked for authorisation prior to the command prompt opening. You may simply need to press the Continue button if you are the administrator or insert the administrator password etc.

6/ In the Command Prompt window, type: sfc /scannow and then press Enter

7/ A message will appear stating that 'the system scan will begin'

8/ Be patient because the scan may take some time

9/ If any files require replacing SFC will replace them. You may be asked to insert your Vista DVD for this process to continue

10/ If everything is okay you should, after the scan, see the following message "Windows resource protection did not find any integrity violations"

11/ After the scan has completed, Close the command prompt window

  howard64 09:54 23 Nov 2012

thanks Fruit Bat /\0/\ I set it to manual as you suggested but sfc would not run with the message as above. I then went back into services and tried to start Windows Modules - I get the message error 2: the system cannot find the file specified. I am begining to think that prior to bringing the laptop to me they had a virus which when cleaned wiped out part of the os.

  Fruit Bat /\0/\ 11:25 23 Nov 2012

If Microsoft's Checkdisk (chkdsk) failed to repair the MFT, run TestDisk.

In the Advanced menu, select your NTFS partition, choose Boot, then Repair MFT.

TestDisk will compare the MFT and MFT mirror (its backup). If the MFT is damaged, it will try to repair the MFT using the backup. If the MFT backup is damaged, it will use the main MFT.

  lotvic 11:27 23 Nov 2012

These guides from beepingcomputer repair Windows Vista could help

  howard64 09:21 26 Nov 2012

thanks all - Fruit Bat /\0/\ where is "testdisk" as I cannot find it? I have compared the services on this laptop with those on another vista pc and found that the windows module installer is stopped and I cannot start it I get the message "error 2 cannot find specified file"

  howard64 10:52 01 Dec 2012

I have now set the laptop back to factory settings and updates are downloading.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Huawei MateBook X Pro (2019) review

Nvidia’s Gaugan tech turns simple colour blocks into realistic landscapes

New AirPods 2 launch: Release date, price, features & specs

AirPower : date de sortie, prix et fiche technique