vista driver for pluscom 7 port powered usb hub

  harpo63 17:06 24 Jul 2007

Hi Folks

Running vista home basic and I lamely try to import my guitar playing and digi drums etc into my laptop - dell inspiron 1501 with 2GB ram. I have a couple of other instruments to connect via midi to usb converters and i will be using the laptop for software mixing etc using cubase sx. Realise will need a powered usb hub due to number of connections, bandwidth and power draw etc so bought pluscom 7 port aluminium powered hub.

No drivers cam with it and after being recognised by the OS it works for a short while then hangs completely. vista is up to date and keeps telling me the drivers I have are the latest and most appropriate

Have tried generic drivers off the net but nothing seems to resolve this. Have tried with only one or two devices attached such as key board or mouse but still the same problem.

Only on checking the aftersales notice (ebay de-er) did i see the item description advised fit for vista but the detailed dexcription didn't (doh!)

anyhoo - not worth hassle of returns etc but if anyone has a workaround or link to an appropriate driver it would be most welcome

Many Thanks



  crosstrainer 17:15 24 Jul 2007

Update your motherboard drivers, thats about the only thing I can suggest
You need to remove the suspect usb device first from device manager.

Download the latest chipset drivers from:
click here=

  harpo63 12:31 25 Jul 2007


Thanks for your suggestion - tried the new bios released early july as suggested - still same probs. Thank you anyway for your help

anyone else any other solutions please?




  crosstrainer 13:01 25 Jul 2007

I didn't mean upgrade the BIOS, I'm refering to th CHIPSET drivers (these control and manage the resources on your mobo, including USB.

  Totally-braindead 13:10 25 Jul 2007

A hub powered or unpowered should just use a generic driver that should be part of windows. If the device works for a while and then fails I would think the device might be at faulty and may actually be faulty. The only other thing I can think of is thats theres some sort of power down option to save power and this is somehow being activated.
When it fails, do the other USB ports (the ones on your PC not the hub) still work. If so then you're left with either the hub being faulty or possibly Vista not liking it.
I know this isn't really a solution but if you could try it on a mates PC using XP you could at least cut down the options.
Alternatively buy another hub, I realise yours is a 7 port one but you could get another one click here= there are 2 trust 7 port powered ones listed £13.99 and £13.49.

  harpo63 00:52 26 Jul 2007

crosstrainer - thanks for this - I actually meant the chipset drivers downloaded from dell support (not bios! doh! my bad). Thanks for double checking though

Mr Braindead - thanks for the suggestion - have tried with my xp pc at home and it works no probs so it must be the vista os not liking the hub for whatever reason. thanks for the link, have ordered another hub that is vista compatible for def!

Thank you all for your help, I'll relist if any probs with the new hub


This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Honor 9 Lite review

How Social Media has Propelled Political Graphic Design and Art in the Last Decade

The best kids apps for iPhone & iPad 2018

HomePod d’Apple : date de sortie, prix et fiche technique