A virus has wiped ...........

  Dirty Dick 18:56 10 Nov 2008

.. my hard drive, I THINK.

I was downloading a file, when AVG Free intercepted something, and it shown that a lot of files needed to de deleted , so I did.

Now I can't get my Desktop PC to start. I WAS running Windows XP Pro, I thought there was a problem when I tried to click on Start, All Programs and that was showing empty. Then the Start button. Now when I try to start the PC I get a message saying that "NTLDR is missing".

I've Googled for a solution, but all I can find is suggestions to make "recovery disk", the Desktop PC DOES have a floppy slot, but I have no access to download onto a floppy, my modern laptop only has a DVD recorder or USB connections.

Can any one suggest a solution for me?



  hiwatt 19:06 10 Nov 2008

The first thing I would try is booting into safe mode and choosing "last known good configuration" and hope that it works.Can you do a system restore?

  Forum Editor 19:06 10 Nov 2008

that's the first thing to remember. You say that AVG intercepted something when you were downloading a file - what was the file? When you say that AVG told you that a lot of files needed to be deleted, what files do you mean?

Have you checked in your computer's BIOS settings to make sure that it is set to boot from your hard drive, and not from some other drive?

  Dirty Dick 19:21 10 Nov 2008


When I restart the PC, I get a lot of info whizzing past, things like "detecting IDE drives" then there are the "PCI device listing" and at the bottom of the screen it says "Verifying DMI pool Data .." foloowed by "NTLDR is missing - Press Cntr + Alt + Del to restart"

So I cant get into safe mode, or system restore.

Forum Editor

It was a file from an e-mail attachment, from someone I dont know !!! I'm hoping that its just a coincidence that it happened at this time, but I like your statement saying that "Viruses don't wipe hard drives"

AVG opened up saying that there were several threats detected, and suggested removing them, so I clicked ok

  Dirty Dick 19:24 10 Nov 2008

I have checked that the BIOS is set to boot from Hard Drive, and I have two hard drives on the pc. I have changed to the other hard drive and I get a bit further, it gives me the option to start in safe Mode, or last known good configuration, it then attemps to boot, get the Windows logo, then the screen goes blue with some white writing, but too fast to read.

  woodchip 19:29 10 Nov 2008

If you have a full XP disc and the Key, Do a Windows repair. Set Bios to have CD as first boot device followed by what they are now, save and exit then start with windows CD click setup, windows will do a search for any operating systems, it should show a box with your OS click on the OS it found then press R for repair

  Dirty Dick 19:42 10 Nov 2008

I've put XP disc that came with the PC in, and changed the boot order so that CD is 1st. It runs aa before then "Verifying DMI Pool Data ...." then "Boot from CD :" then comes NTLDR is missing, nad Press Ctrl/Alt/Del to restart.

Still no Joy !!

  woodchip 19:43 10 Nov 2008

Is it a full XP disc or restore disc? as Repair will not work with a Restore disc

  woodchip 19:45 10 Nov 2008

Also when it says boot from CD you have to press enter key

  Dirty Dick 19:53 10 Nov 2008

Not sure about the disc as to whether its a full or re-store. Its the one that came withe the PC.

Also. just tried again and pressed Enter when it said boot from CD, but still same result (or not !!) The CD drive seems to start to run but it comes up with "NTLDR is missing" befor it gets to full speed.

  woodchip 20:02 10 Nov 2008

Then its a restore disc, as its switching to the Hard Drive that triggers the Message. You cannot do a repair using that method, you can only do a full restore to Factory settings. If you have got your files of it should work by pressing the appropriate key or keys to start restore with the cd in the drive. put the CD in then Press Alt+F10 when its starting it may work

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Dell XPS 13 9370 (2018) review

No need to scan sketches into your computer with Moleskine's new smart pen

HomePod review

Streaming : Netflix ou Amazon Prime Video ?