Very slow speeds - netgear wnr834b v2

  kelemvor 22:14 06 Sep 2008


I've recently replaced my old router with a netgear wnr834b v2 rangemax N, I have set up the wireless connection (though it was very slow even when wired during config) but even though I can connect to it, I get very low speeds - in fact it's as bad as being on a 56k modem (it's really that slow and I'm sitting next to it). It also seems to drop out every so often. I have upgraded to the latest firmware and am running it at 130Mbps (as I'm still on b/g).

My flat mates seem to be ok, but they are connecting via the electricity supply rather than wireless.

I'm currently running Ubuntu on a dell latitude (with built in broadcom wifi), but don't think that this should cause any issues as my previous router (and another netgear) worked fine with this setup.

I have tried choosing a channel rather than using auto as I read somewhere that there may be interference from other local wifi connections, but this didn't do anything, I've also tried removing the wpa encryption temporarily, but this has no effect either.

Has anyone got any suggestion that I could try?

Thanks guys

  Ashrich 01:35 07 Sep 2008

Can you try running the router at 54mb/s ( g ) , or if it has a combination of all modes ( b , g , n ) because running it at 130 only may cause problems if oyu are only accessing it at a slower speed .


  Ashrich 01:40 07 Sep 2008

Also make sure that transmitter and receiver are on the same channel .


  kelemvor 06:59 07 Sep 2008

I've tried running at 54Mbps (270 doesn't work as we don't have any N compatible wifi cards etc)

How do I select the channel that's used on my laptop?

  Ashrich 15:32 07 Sep 2008

You can select it from Device Manager / Network Adapters / Advanced or from the supplied utility software that may have been supplied with the PC


  Ashrich 15:35 07 Sep 2008

Just re-read the original post , you are using Ubuntu , sorry , I don't know where to look in there .....


  kelemvor 12:09 14 Sep 2008

Yahooo !! Ok well I played around with my channel settings and it's now worked. Thanks you guys !

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

AMD Radeon Adrenalin release date, new features, compatible graphics cards

Indie publisher Canongate’s top 10 book covers of 2017

New iMac Pro release date, UK price & specs rumours

Tablettes Amazon Fire : quel modèle choisir ?