Very slow internet connection

  lenchez 15:31 18 Feb 2010

Internet connection was getting very slow, this coincided with getting error message "There was an unexpected error: Class not registered (0x800401540". Have reinstalled Vista and the error messages have gone but internet is still painfully slow. I go via cable from my desktop into a belkin wireless router (F5D7632-4) My kids have their laptops and my son plays COD 4 on his PS3 all through this router. If I have the cable in then the internet is slow or fails to open sites and my son cant play on the PS3, if I remove the cable then the laptops and PS3 work fine, no problems. I have tried a new cable and I have tried a new belkin PCI network card but the problem persists. Any ideas???

  rizlo29 15:40 18 Feb 2010

As it always been like this with so many connections, or has something got faulty? I'm guessing it could have something to do with firmware update. This is were your isp update router with software.

Sometimes the updates play with settings and make things worse. If you log into the router, it will tell you when the last update was. Then you can check dates and see if thats when things went wrong.

  User-1229748 15:44 18 Feb 2010

open network and sharing center and right click ethernet adapter and click diagnose or troubleshoot.also while there right click again and select properties and untick ipv6.worth a shot anyway.

  User-1229748 15:46 18 Feb 2010

you might want to update drivers aswell or go to your pc manufacturers site and download drivers from there

  retep888 16:01 18 Feb 2010

Try updating your router's firmware

click here

  lenchez 16:16 18 Feb 2010

I have vista home premium 32 bit. Up until several weeks ago I could be on my desktop (wired) on the net with my son and daughter on their laptops (wireless) and my son playing COD 4 on his PS3 (wireless) all with no problems. However one day the internet started to go very slow, this coincided with error messages and the inability to do backups, system restores and use the snipping tool. I have reinstalled vista from the manufacturers disc (dell). I reinstalled drivers as per dells instructions. I run the diagnose and repair option and it says there are no problems. I update drivers but it comes back and says the driver is upto date. The firmware for the router is dated 2005 so I updated that to 2005 again. I've even reinstalled them again but to no avail. If I just pull out the cable that connects my desktop to the router then everything is ok, apart from the fact that I can then not get on the net.

  retep888 16:51 18 Feb 2010

If it still fails after you've tried on a new pci network card and different ports on the router then might be time for a new router?

Or alternatively buy a wireless pci network card for the desktop and connect to internet.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Huawei MateBook X Pro review

8 digital brands that designed custom typefaces to save millions

How to speed up a slow Mac

Comment résoudre des problèmes d’impressions ?